summaryrefslogtreecommitdiff
path: root/dev-python/gsd/gsd-3.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-23 10:47:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-23 10:47:12 +0000
commit02d5de423c2b7f8d7c873bcc7a1a222b1847149d (patch)
tree29d109245f3aa2842c63489c8ec537f85e92ff41 /dev-python/gsd/gsd-3.2.1.ebuild
parent0770f5276c9044be774368cba8d9d8ce7a43627a (diff)
gentoo auto-resync : 23:01:2024 - 10:47:12
Diffstat (limited to 'dev-python/gsd/gsd-3.2.1.ebuild')
-rw-r--r--dev-python/gsd/gsd-3.2.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/gsd/gsd-3.2.1.ebuild b/dev-python/gsd/gsd-3.2.1.ebuild
new file mode 100644
index 000000000000..367cf1319642
--- /dev/null
+++ b/dev-python/gsd/gsd-3.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="GSD - file format specification and a library to read and write it"
+HOMEPAGE="
+ https://github.com/glotzerlab/gsd/
+ https://pypi.org/project/gsd/
+"
+SRC_URI="
+ https://github.com/glotzerlab/gsd/releases/download/v${PV}/${P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-python/numpy-1.24.2[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs gsd
+}