summaryrefslogtreecommitdiff
path: root/dev-python/gsd/gsd-2.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-24 14:55:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-24 14:55:44 +0100
commitb83b16e0f6c963583f6323fe1bb12ecbd11d6f81 (patch)
treed67748047921162af2742c3e1255e3f1421f769b /dev-python/gsd/gsd-2.8.0.ebuild
parent76617568771869151cb2a3f71939719c15dd47a2 (diff)
gentoo auto-resync : 24:07:2023 - 14:55:44
Diffstat (limited to 'dev-python/gsd/gsd-2.8.0.ebuild')
-rw-r--r--dev-python/gsd/gsd-2.8.0.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/gsd/gsd-2.8.0.ebuild b/dev-python/gsd/gsd-2.8.0.ebuild
deleted file mode 100644
index 6a8af0f7eea3..000000000000
--- a/dev-python/gsd/gsd-2.8.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-MY_P=${P/-/-v}
-DESCRIPTION="GSD - file format specification and a library to read and write it"
-HOMEPAGE="
- https://github.com/glotzerlab/gsd/
- https://pypi.org/project/gsd/
-"
-SRC_URI="
- https://github.com/glotzerlab/gsd/releases/download/v${PV}/${MY_P}.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
- >=dev-python/numpy-1.23.4[${PYTHON_USEDEP}]
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- cd "${T}" || die
- epytest --pyargs gsd
-}