summaryrefslogtreecommitdiff
path: root/dev-python/griffe/griffe-0.32.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-14 10:36:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-14 10:36:56 +0100
commit5af5a2b4acc97daacc0bf0e1d4e85ec780734689 (patch)
treec3e48a276c7fda27c8e30b6b8864e178e5c496fb /dev-python/griffe/griffe-0.32.0.ebuild
parent605eb6cd753ab91e58e7561ebad2e75a44bcccc4 (diff)
gentoo auto-resync : 14:07:2023 - 10:36:56
Diffstat (limited to 'dev-python/griffe/griffe-0.32.0.ebuild')
-rw-r--r--dev-python/griffe/griffe-0.32.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/griffe/griffe-0.32.0.ebuild b/dev-python/griffe/griffe-0.32.0.ebuild
new file mode 100644
index 000000000000..c8d57610c9ff
--- /dev/null
+++ b/dev-python/griffe/griffe-0.32.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Signature generator for Python programs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/griffe/
+ https://github.com/mkdocstrings/griffe/
+ https://pypi.org/project/griffe/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/griffe/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/jsonschema-4.17.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # fragile to installed packages
+ # (failed on PySide2 for me)
+ tests/test_stdlib.py::test_fuzzing_on_stdlib
+)