summaryrefslogtreecommitdiff
path: root/dev-python/graph-tool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/graph-tool
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/graph-tool')
-rw-r--r--dev-python/graph-tool/Manifest4
-rw-r--r--dev-python/graph-tool/graph-tool-2.45.ebuild84
-rw-r--r--dev-python/graph-tool/metadata.xml6
3 files changed, 90 insertions, 4 deletions
diff --git a/dev-python/graph-tool/Manifest b/dev-python/graph-tool/Manifest
index 180aed07514e..98d68264359b 100644
--- a/dev-python/graph-tool/Manifest
+++ b/dev-python/graph-tool/Manifest
@@ -1,4 +1,6 @@
DIST graph-tool-2.44.tar.bz2 15149379 BLAKE2B d15413f4e8642b96f62d88631c216e600e24aa878b08a173f1a00f1700aa3c6f4b1b3f806956b811b209a2d42ec1178e2488946d96f056f528a046cbd6cc330a SHA512 b90dc541ec77f89fdbb64697ec5e200d9c7c4ec4b8849c75d008b83dab8f54c95bd230f5d72e32d656f86a201ab66eee25aa774b7983355f7af9304b52527e40
+DIST graph-tool-2.45.tar.bz2 15156784 BLAKE2B b9086e5545ace668f703bf06363a382fab734a63d5684d44b62407a06a0464df6a4a9c8c7ccd26e53118c1d24469ed2eb4670939dc0889fafe2f73a2c176101b SHA512 46a4a3a22033c74c69e0ba5ce8f0856d2f35934d52850ef4a542384c8fd327daf56341675a3299a8db87d4a227b5583f0564f8917ecf28081cb1dd4091563490
EBUILD graph-tool-2.44-r1.ebuild 1785 BLAKE2B 1dae12b7f1db9969a4ec851a1c04d10106a517c5ff77ddbd5ae20a940fd682692909b7a23abc6d453c75f8cae27e639d18bfd8cf859895ceb896807602806113 SHA512 f9d462ade4e9fa59ac36ae2ae91581a6a8ec84603be356145a535bce8d24aba7bc1107710de80d64b33236bbe661400aed70de8d8083fc745bfefcddef58fcf9
+EBUILD graph-tool-2.45.ebuild 1785 BLAKE2B 1dae12b7f1db9969a4ec851a1c04d10106a517c5ff77ddbd5ae20a940fd682692909b7a23abc6d453c75f8cae27e639d18bfd8cf859895ceb896807602806113 SHA512 f9d462ade4e9fa59ac36ae2ae91581a6a8ec84603be356145a535bce8d24aba7bc1107710de80d64b33236bbe661400aed70de8d8083fc745bfefcddef58fcf9
EBUILD graph-tool-9999.ebuild 1785 BLAKE2B 1dae12b7f1db9969a4ec851a1c04d10106a517c5ff77ddbd5ae20a940fd682692909b7a23abc6d453c75f8cae27e639d18bfd8cf859895ceb896807602806113 SHA512 f9d462ade4e9fa59ac36ae2ae91581a6a8ec84603be356145a535bce8d24aba7bc1107710de80d64b33236bbe661400aed70de8d8083fc745bfefcddef58fcf9
-MISC metadata.xml 437 BLAKE2B da394a6ff65e5104c8cad22c123355d6cce752578627e74eaccdbb4ac11ef44c131f2133bc7fb9a35016e47b09dbf5a60a88d5ba25be0a7c6b131747aa85c310 SHA512 460b62839edfaba3f15bcc80aac5900258e243dda4bb85dc3a77492077bf1a09aa308458d40831bc5efd785f40c4a643a7b8360c36045e977102302c03d5877f
+MISC metadata.xml 441 BLAKE2B ad80736b2b28a13828593d542c82b64a64f03a655faa1aeeed9b6f33f6625224bbf3bc6b33220cf994221a9bf9d384cdc45a5298112c8b225f38f0bdcca7b486 SHA512 4dc6ae46ce91eb7e9f3e0a7737a5bf0bc0d280936c5dbaaa14ff1d67225243a377e6cc6d8505c2f449c7d35c72ea85b01e83df207bf1ea151f87934c20e616d6
diff --git a/dev-python/graph-tool/graph-tool-2.45.ebuild b/dev-python/graph-tool/graph-tool-2.45.ebuild
new file mode 100644
index 000000000000..f45d24d4fbfe
--- /dev/null
+++ b/dev-python/graph-tool/graph-tool-2.45.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit check-reqs python-r1 toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://git.skewed.de/count0/graph-tool.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://downloads.skewed.de/${PN}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="An efficient python module for manipulation and statistical analysis of graphs"
+HOMEPAGE="https://graph-tool.skewed.de/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+cairo openmp"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/boost-1.70:=[context,python,${PYTHON_USEDEP}]
+ dev-libs/expat
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ sci-mathematics/cgal:=
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ cairo? (
+ dev-cpp/cairomm:0
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ x11-libs/cairo[X]
+ )"
+DEPEND="${RDEPEND}
+ dev-cpp/sparsehash"
+BDEPEND="virtual/pkgconfig"
+
+# bug 453544
+CHECKREQS_DISK_BUILD="6G"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+ check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+ python_copy_sources
+}
+
+src_configure() {
+ my_configure() {
+ econf \
+ --disable-static \
+ $(use_enable openmp) \
+ $(use_enable cairo) \
+ --with-boost-python="boost_${EPYTHON/./}"
+ }
+ python_foreach_impl run_in_build_dir my_configure
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir emake
+}
+
+src_install() {
+ my_python_install() {
+ default
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir my_python_install
+
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/dev-python/graph-tool/metadata.xml b/dev-python/graph-tool/metadata.xml
index ad3821fd4c39..658ec6ce0349 100644
--- a/dev-python/graph-tool/metadata.xml
+++ b/dev-python/graph-tool/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
+ <maintainer type="person">
+ <email>soap@gentoo.org</email>
+ <name>David Seifert</name>
</maintainer>
<maintainer type="person" proxied="yes">
<email>gentoo@chymera.eu</email>