summaryrefslogtreecommitdiff
path: root/dev-python/gpep517
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-11 01:28:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-11 01:28:44 +0100
commitb46b9834b3fbf80b22ccc12e95f660512cd0fa75 (patch)
treef7eb18ccc89e078e2f175e5249fe0d4dfdb5b104 /dev-python/gpep517
parent62f7102650b24618880e8e6f08fcb8fbd235025b (diff)
gentoo auto-resync : 11:07:2022 - 01:28:44
Diffstat (limited to 'dev-python/gpep517')
-rw-r--r--dev-python/gpep517/Manifest1
-rw-r--r--dev-python/gpep517/gpep517-6.ebuild44
2 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/gpep517/Manifest b/dev-python/gpep517/Manifest
index b4bcdd92ec33..dcc8c2bc3595 100644
--- a/dev-python/gpep517/Manifest
+++ b/dev-python/gpep517/Manifest
@@ -1,4 +1,3 @@
DIST gpep517-6.gh.tar.gz 9757 BLAKE2B f1b39f30b7d775330bddfd353610de7c26e34c5572cdaedbb078cc61c711e90e1c520b5e6e5532b0879ccc1eb7025a793c6f8d9745d93967eabbdd9edef69c6a SHA512 681108dab418d0d2d5b017f19bf8802479655f22eb6b72e9d78c6bbd2d08583751a465377c2006c507f0ea258d2d46bf9300865896af4458a763b56a86abe329
EBUILD gpep517-6-r1.ebuild 1049 BLAKE2B ffefd17881bcd87f3e59dae9d87de5d2e51d10e713d5ee8d7778b43909cb82f9610fa3d52c7d271a3cb4375a00683eee1223b9343e93199f233328dbd0a2452a SHA512 f97dac4152bbecc7394fdabf7af6b4a0600979280d33bfc360ae988bd54c380fee448d9758de97e2206c93709903f917adf24a7ece610b3c1d9e0b5dca06e9cc
-EBUILD gpep517-6.ebuild 1135 BLAKE2B 5141d573049a49bc8631f72380f4397c3e1fd5192080fa1dd1f81f6ee31e608e9e63bcbc6d25ecf228610a15602b202260b184ff659de06cd7fccd2695726954 SHA512 73ba576b4f6eba8b9a2cf6d873272db739f70fef7da001311b1fb111eb9c9258b9c6f1cf3f697c438db407b9521d07e7c5f5b6d802e322482c28a28950fe9602
MISC metadata.xml 396 BLAKE2B a3f6d1cea383a38b4b6e5f80d2306ca320a66c0d3b0131601ef6f0ea48483757b9123d74ba99fe972dde06a998c15290cbc4243285c240493ae0293d2f8e1141 SHA512 8c584869f2fc7a0947b9e5ffa330652d8b6e61a6a472fcddf0422f1719422fb8d477cdf17d87e6d0e9f6994d608a77202c24e531dd146b0f8d731a047f80d14e
diff --git a/dev-python/gpep517/gpep517-6.ebuild b/dev-python/gpep517/gpep517-6.ebuild
deleted file mode 100644
index 8dfcfc0113db..000000000000
--- a/dev-python/gpep517/gpep517-6.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=manual
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A backend script to aid installing Python packages in Gentoo"
-HOMEPAGE="
- https://pypi.org/project/gpep517/
- https://github.com/mgorny/gpep517/
-"
-SRC_URI="
- https://github.com/mgorny/gpep517/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="
- >=dev-python/installer-0.5.0[${PYTHON_USEDEP}]
- >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-# do not use any build system to avoid circular deps
-python_compile() { :; }
-
-python_install() {
- python_domodule gpep517
- python_newscript - gpep517 <<-EOF
- #!${EPREFIX}/usr/bin/python
- import sys
- from gpep517.__main__ import main
- sys.exit(main())
- EOF
-}