summaryrefslogtreecommitdiff
path: root/dev-python/gpep517/gpep517-13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-25 23:26:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-25 23:26:34 +0100
commit04092be5ecd421ee24c421b2e57b6379f55e0ca1 (patch)
tree9984386d8b11eab1989daeee01f3bd0d6a9f306c /dev-python/gpep517/gpep517-13.ebuild
parent7ca727413163c0e381621a04aec80b0b9d3671dc (diff)
gentoo auto-resync : 25:09:2023 - 23:26:33
Diffstat (limited to 'dev-python/gpep517/gpep517-13.ebuild')
-rw-r--r--dev-python/gpep517/gpep517-13.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/gpep517/gpep517-13.ebuild b/dev-python/gpep517/gpep517-13.ebuild
deleted file mode 100644
index e1b324df4976..000000000000
--- a/dev-python/gpep517/gpep517-13.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=no
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="A backend script to aid installing Python packages in Gentoo"
-HOMEPAGE="
- https://pypi.org/project/gpep517/
- https://github.com/projg2/gpep517/
-"
-SRC_URI="
- https://github.com/projg2/gpep517/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-
-RDEPEND="
- >=dev-python/installer-0.5.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
- ' 3.{9..10})
-"
-
-distutils_enable_tests pytest
-
-python_install() {
- python_domodule gpep517
- python_newscript - gpep517 <<-EOF
- #!${EPREFIX}/usr/bin/python
- import sys
- from gpep517.__main__ import main
- sys.exit(main())
- EOF
-}