summaryrefslogtreecommitdiff
path: root/dev-python/google-reauth-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/google-reauth-python
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/google-reauth-python')
-rw-r--r--dev-python/google-reauth-python/Manifest1
-rw-r--r--dev-python/google-reauth-python/google-reauth-python-0.1.0-r1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/google-reauth-python/Manifest b/dev-python/google-reauth-python/Manifest
index 71a132c52d21..ae69f928fdee 100644
--- a/dev-python/google-reauth-python/Manifest
+++ b/dev-python/google-reauth-python/Manifest
@@ -1,3 +1,4 @@
DIST google-reauth-python-0.1.0.tar.gz 17720 BLAKE2B c78a43f1062988ada715c9e1bb64c2252a3debd5b9b366df9780200717a006c5e4957bf37d81e645989c6fc74c5e5b4354c88244309bb1a22a936ef74f6172c8 SHA512 b92b822b5c59d74f7ac747e66f35eaa906a0e18ccbb791e0904551c6ecd9b904ac7602ea38333a16396ffa49638a1b4991827429c7f52311b9506f55400bf117
+EBUILD google-reauth-python-0.1.0-r1.ebuild 1074 BLAKE2B 51bd0bc227a5eb1a10671c97cbe779418125baee8030c9ca9219fe14668037c8eb12a5f8cba15794d4ffe68a5d50565b11b60dd7cd0a3d53212c326e5a9253c7 SHA512 e1e946ef98931376211e0a5cc674cca112548ee01111d86e300858c6d931c8bf43ac291de42047da9c444b1dc188b432f136c6fb6fa2fefe0ee8747ff2d950ea
EBUILD google-reauth-python-0.1.0.ebuild 1119 BLAKE2B a8dd833fbacccb46e5697078c58823f80c52b30ebb1b60dd93fbb786cea0b1e36fede555e24e067919139031871fd93eed2e671f9a2fde3740f68637bba4147a SHA512 f3a713385df277ed0bc7cca819dc94f4e2b2f325e7fbb61a5e43cd7d211db20b2439220dee8989975f1b99817dd81e33d5c1a5bdaf19b337d6b9c31956d4ebc6
MISC metadata.xml 387 BLAKE2B 3c273fa005cf2d68f977f8556723ae4577d05998471f3cd845f7335c84c610d4d4af9c971b6ee2edcf51b621e24eaf2083c20dabad714111b2d21cc99116d376 SHA512 7fcd5ff43d0f70d110f62c197f5e8f4ed6bf3192c457402c0d4bfdda66f32ba5144008d07e87d1661289ffaf1f2b637f7467dc1a50b65cf6606c17caf283b96a
diff --git a/dev-python/google-reauth-python/google-reauth-python-0.1.0-r1.ebuild b/dev-python/google-reauth-python/google-reauth-python-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..d9c8d75a6df2
--- /dev/null
+++ b/dev-python/google-reauth-python/google-reauth-python-0.1.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python based U2F host library"
+HOMEPAGE="https://github.com/google/google-reauth-python"
+SRC_URI="https://github.com/google/google-reauth-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGELOG.rst CONTRIBUTING.rst README.rst )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s:'some_origin'.encode('ascii'):'some_origin':" \
+ -e "s:SignResponse('key_handle', 'resp',:SignResponse('key_handle'.encode(), 'resp'.encode(),:" \
+ -i tests/test_reauth.py || die
+
+ distutils-r1_python_prepare_all
+}