summaryrefslogtreecommitdiff
path: root/dev-python/google-pasta
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-21 17:32:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-21 17:32:00 +0100
commit61f10f985e19dfe20a4d9552902625edd5b6eabb (patch)
tree50db31971b38c4e0358253ef5005058a46fc773e /dev-python/google-pasta
parent34dea8e38f88007799629d0a56b12dec480b1d21 (diff)
gentoo resync : 21.06.2021
Diffstat (limited to 'dev-python/google-pasta')
-rw-r--r--dev-python/google-pasta/Manifest1
-rw-r--r--dev-python/google-pasta/google-pasta-0.2.0-r1.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/google-pasta/Manifest b/dev-python/google-pasta/Manifest
index bae257bbda35..e97894c0d82d 100644
--- a/dev-python/google-pasta/Manifest
+++ b/dev-python/google-pasta/Manifest
@@ -1,3 +1,4 @@
DIST google-pasta-0.2.0.tar.gz 40430 BLAKE2B b3f068c0530149d6e8057a2e7edeb76b1912516a8227a837913783060e30f418159b38c77480248dc7a1586b46c9b5914e93c77a9430d963b3538e2197661922 SHA512 1d75d994a5120109677a58472459a632b31568e6ce79b205688913dc2a94e132fad818c73510b2f7d7adca3c757077543abd8b7f15be035a63fa15d38874c753
+EBUILD google-pasta-0.2.0-r1.ebuild 516 BLAKE2B 90740cfcfeaea7c638d876cdf1da794f20cb51b7b49e7e8dd7890e6d822984c45ff793751caa82c7c7b48d0f825ca4244c33d03dd4ad15cf850e5d8e8b53e358 SHA512 0fd6165cbbbf80ec67e1bb00d237798cc0ce5cad17068c02cad851cee4697c5312d188621fa1b21329cb923fee17e307c34294b5ea1870404f69404604ba4078
EBUILD google-pasta-0.2.0.ebuild 483 BLAKE2B 441184ba38db59f401471acb789850f979c1e300092388f4e698c232fc05d7fef746de1f379933f9f563b5a2c344639211ba362faae77102612d75753b9173ff SHA512 f3d22898ff4c200d46692848f5749fc579ca464591ba19ed0cc6b7d00c0af2ee1e3939431599fb95f6c715bb7cc2974a2312e47bce3568d009a4150e684a7799
MISC metadata.xml 322 BLAKE2B 2c65b78f40b5805ffd54dd2c4d9e6b2c142888ce77b6885461f972b744c11a41466e26bdc2cb21fe24425bac32af8676315a42d69a7781e2031659f8693e552b SHA512 3bac4b24cefe900f5ca789cc1b3828002ec4a1041c7b6c9f4610ffa73ee98ce81dba823fc9b65af591c9b57c9b3e14be10bdeca77e952627dbd6f12977395e38
diff --git a/dev-python/google-pasta/google-pasta-0.2.0-r1.ebuild b/dev-python/google-pasta/google-pasta-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..36a3aa54a23a
--- /dev/null
+++ b/dev-python/google-pasta/google-pasta-0.2.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="AST-based Python refactoring library"
+HOMEPAGE="https://pypi.org/project/google-pasta/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py