summaryrefslogtreecommitdiff
path: root/dev-python/google-i18n-address/google-i18n-address-3.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
commitdb70871b2044b9bfde346d6f4027dafb0a013c4c (patch)
tree34548aee54e5458d3754bd8c8f987acdb5ee444c /dev-python/google-i18n-address/google-i18n-address-3.1.0.ebuild
parent1c382dc5dbc52576ac2300fee0498af8af44e7b4 (diff)
gentoo auto-resync : 15:06:2023 - 13:38:09
Diffstat (limited to 'dev-python/google-i18n-address/google-i18n-address-3.1.0.ebuild')
-rw-r--r--dev-python/google-i18n-address/google-i18n-address-3.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/google-i18n-address/google-i18n-address-3.1.0.ebuild b/dev-python/google-i18n-address/google-i18n-address-3.1.0.ebuild
new file mode 100644
index 000000000000..514b69a1c503
--- /dev/null
+++ b/dev-python/google-i18n-address/google-i18n-address-3.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google's i18n address metadata repository"
+HOMEPAGE="
+ https://github.com/mirumee/google-i18n-address/
+ https://pypi.org/project/google-i18n-address/
+"
+# Using the github release, as it contains the tests (unlike the pypi artifact).
+SRC_URI="
+ https://github.com/mirumee/google-i18n-address/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest