summaryrefslogtreecommitdiff
path: root/dev-python/google-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-13 13:36:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-13 13:36:46 +0100
commit7b02e37a04e4051a91a109814d386711f41f9a4b (patch)
treed0689f14f1d1df3a6a2525512a6812b146064a9e /dev-python/google-auth
parent5c0c70d5917e66743293789a6d6fd7d72250eb32 (diff)
gentoo auto-resync : 13:07:2022 - 13:36:46
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest2
-rw-r--r--dev-python/google-auth/google-auth-2.9.1.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 5a680cd6648b..c16c51b02e9f 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,3 +1,5 @@
DIST google-auth-2.9.0.tar.gz 205241 BLAKE2B 3e33b3c404d0fbd8b4c0b02c6187103c5715dad0f8850b895c91cecca81c2b2adce1b6426eccb8fa5c94948b53978b8530c54c59749e54af5b9513ce23497f6a SHA512 2bcdf7c80d588f8229808e35426cf07ff1e14e778deb315ed375cb2c17a7efcec848c3cd2aa1ab8cd9c8550cd1e79eba9345c84d44f513844dfe1928e42a189d
+DIST google-auth-2.9.1.tar.gz 205219 BLAKE2B dd4d3c690a4ced2d4757167497689283b7fd8e9891948f0f14565fffe0d0c9eb62c4356a5715d10d02fefd1183bda5dfe3b1e7a7caa42c8d85c39c5875fd9730 SHA512 37830c708613f3a41c90658f220c2cd7ca45824c7e4741fa3b1754e635f6e0773daff05f770ad0836caefe082d6b517b5bd5b2a789cdbe03de9fdbca9a972f7f
EBUILD google-auth-2.9.0.ebuild 1525 BLAKE2B 0559fae14e6b27d48b0a8cf5babe40d71283d26581e6bc1c2efb0e9c20b7757ba820fbed34dd73b32198cbde9f2b3a620b9d27156ef9847a875908ce663a3e63 SHA512 e9ade71009eea68d39214942b376aff7aa4c1660e29cc2bbc535f7e0f40fdbe0ec30140dd4a21dd503531577ee6c183ec78fcf433f4898f819c620be02dceda1
+EBUILD google-auth-2.9.1.ebuild 1527 BLAKE2B 6a9c5ae6fe4de702e737e491d692c91e0b44ba3961a2f965489614220fd641cf0416ced1ee0bfd910730268c14406d27e12a224499004a9d2a41f258726c33b7 SHA512 e64349d2b54a4be4fc33d37faec791ac61459ae7cc4143758bc47b3d593f8c440ea4114dea463318f2706d1c597c6c248a81117908ab5b6f5304e0ea63ae521d
MISC metadata.xml 521 BLAKE2B 784282f6a173e7746a408556d77e1277f65a41eae545b6b26054c1e506642e683c1c7d91798f3b7b690bc4f9d2f642a51c1395593177eebf1770d2a0c0ba589e SHA512 c2624ebca3dc42961e61531db4724b2b354a722f71cd7f2c194680fee50125d2251f4b94cc7e31b008a2792e74b0f55f407a1230d3f59572df9cf32ee49d2fb7
diff --git a/dev-python/google-auth/google-auth-2.9.1.ebuild b/dev-python/google-auth/google-auth-2.9.1.ebuild
new file mode 100644
index 000000000000..de5188c8fdb8
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.9.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}