summaryrefslogtreecommitdiff
path: root/dev-python/google-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-10 12:20:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-10 12:20:34 +0000
commit79e2fe7ce5d8192f7ddc9f57d4fb11bd1231f041 (patch)
tree214e48e63c0393badb2c99be0bc323c046ee2a25 /dev-python/google-auth
parent30f491533785a455cdfbd05bb57f1f869a8e41bb (diff)
gentoo auto-resync : 10:01:2023 - 12:20:33
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest2
-rw-r--r--dev-python/google-auth/google-auth-2.16.0.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index f33fb45c24f1..66cbe46dc8bb 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,4 +1,6 @@
DIST google-auth-2.15.0.tar.gz 221698 BLAKE2B 73decb21ab51889d2f22a2dca9d01f8c7d77a37a5ba186e2fba05bfb7a56f0e5ea0f5c1396c0be527b03e9083e98995e96f0081973e97766fafc6a63946c0015 SHA512 4a564503195e4a96ac2a89bb208c37e434185439533913285ca03a3627f28e641a99224ae285ced84050fdc6073e075b1ba288e9a9c18d3e6adf70509b5ee68b
+DIST google-auth-2.16.0.tar.gz 223336 BLAKE2B 9dbd54bdf072dacdf728f6fc34931f153dd409e3e1b92e37ed652a1db39d5380b7e66bd196cb1192f75234b2317518a443f8f515bc9135f553e6c9f1116fc606 SHA512 dbeff00089a410c6702e2bd704968c7392809dc217b3f511b62429a11649e4b0607a41622d2753bed9e511368b1c32086b23df66ec915e07a1dd4f32471e025d
EBUILD google-auth-2.15.0-r1.ebuild 1526 BLAKE2B f9b3a2c88eff61debb3027b55a995c2b854f07b7ae1f91b27807d7278a006d7e14b592be18d901b2709e14c6d7c593a76a4e9d74604287d511c55f4852122dfa SHA512 403cbbaec7ca6a52ba6ddcae159921ec4eb10505fc70288f7fd9d7536cd40b5ff0ed78202d2ed153358d84c59f3641c87815121a17c2cd30a842028f28ad6bea
EBUILD google-auth-2.15.0.ebuild 1525 BLAKE2B 67d8259c988a6ffb652d19362fe67bb89faccf1abd35fe1a79a95542a7be93bcc5a8d1e0c0b40a81e4ffc46b866ad6f3c07954fedd9d3d8ee983aea2a7a51db2 SHA512 1b59ded41c1b242c00a7a7aa3ce0e13b3ca5c2755f3448c7c0c3110c4bdc779f2484d33fc6fdaecee7efdc0c77b9b67ee8bb1774ad80cc7143914fc02fd1db0e
+EBUILD google-auth-2.16.0.ebuild 1528 BLAKE2B 03210f5a849491656467c2546b55dd9ff27a99851650b9befdf4d90cafc9dc8f3d4e3b081394e867609e3bca81ae63fb10ed0d3361999875bf37b6ca896fe564 SHA512 c8bb384a7d054c0fee6d86bfd50c9df81cf472b6f5eb8280fc6bf0c8a426bdf344da5ea074ae0312fbeaf0bd0d10f22310c053eaf3f3c709a5c1621787747b70
MISC metadata.xml 521 BLAKE2B 784282f6a173e7746a408556d77e1277f65a41eae545b6b26054c1e506642e683c1c7d91798f3b7b690bc4f9d2f642a51c1395593177eebf1770d2a0c0ba589e SHA512 c2624ebca3dc42961e61531db4724b2b354a722f71cd7f2c194680fee50125d2251f4b94cc7e31b008a2792e74b0f55f407a1230d3f59572df9cf32ee49d2fb7
diff --git a/dev-python/google-auth/google-auth-2.16.0.ebuild b/dev-python/google-auth/google-auth-2.16.0.ebuild
new file mode 100644
index 000000000000..5e31f839ad86
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.16.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}