summaryrefslogtreecommitdiff
path: root/dev-python/google-auth/google-auth-2.19.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-24 14:55:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-24 14:55:44 +0100
commitb83b16e0f6c963583f6323fe1bb12ecbd11d6f81 (patch)
treed67748047921162af2742c3e1255e3f1421f769b /dev-python/google-auth/google-auth-2.19.1.ebuild
parent76617568771869151cb2a3f71939719c15dd47a2 (diff)
gentoo auto-resync : 24:07:2023 - 14:55:44
Diffstat (limited to 'dev-python/google-auth/google-auth-2.19.1.ebuild')
-rw-r--r--dev-python/google-auth/google-auth-2.19.1.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-python/google-auth/google-auth-2.19.1.ebuild b/dev-python/google-auth/google-auth-2.19.1.ebuild
deleted file mode 100644
index 124d2751a7f9..000000000000
--- a/dev-python/google-auth/google-auth-2.19.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Google Authentication Library"
-HOMEPAGE="
- https://github.com/googleapis/google-auth-library-python/
- https://pypi.org/project/google-auth/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-RDEPEND="
- <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
- >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- !dev-python/namespace-google
-"
-BDEPEND="
- test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/grpcio[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pyu2f[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- <dev-python/urllib3-2[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # these are compatibility tests with oauth2client
- # disable them to unblock removal of that package
- tests/test__oauth2client.py
-)
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}" -name '*.pth' -delete || die
-}