summaryrefslogtreecommitdiff
path: root/dev-python/google-auth-oauthlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-25 15:53:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-25 15:53:58 +0100
commitb8c48743664466ac0f638f0949fd78bfb9f5eae6 (patch)
treedd60615a286df950811f8267c0631e1fd97eac58 /dev-python/google-auth-oauthlib
parentcf9065b9fe1f8c33a6e488fce1ee75d893cd351f (diff)
gentoo auto-resync : 25:10:2022 - 15:53:58
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/Manifest2
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.6.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
index 8d8bf1e8cdf6..f7926ade1cce 100644
--- a/dev-python/google-auth-oauthlib/Manifest
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -1,5 +1,7 @@
DIST google-auth-library-python-oauthlib-0.5.2.gh.tar.gz 53842 BLAKE2B 7adcd9f339ec9a5528308fcc0fee1cbbe96440e1bfe5c7cc9c94808668e22801b612d291a2419333888194c3224838ac40f9d0656381825bd660067470f58910 SHA512 eaf296a0e0504e8249637a8db7531c10b120f28abeeab3e1fe8f366b4279c396509188e83f8a0ec56be85063430ceb691d6d926cee33d4f166bbcc4425e538db
DIST google-auth-library-python-oauthlib-0.5.3.gh.tar.gz 69613 BLAKE2B 74338894f35fd1cd8802ea56952561ce0e801fecb2f994b71caf3c6b62a22e8b85f8a5b40f5571b05225a565b373865377d321625aeea2dafcc0cafb89da1492 SHA512 76c855e9becd57d3cb3bb0b203ad77ef17dc04e8be8b96d17a9c1f29474a8b180edb725e835d0552c5eddbb387cc463e88b076dd6d11635e6d45798224f09188
+DIST google-auth-library-python-oauthlib-0.6.0.gh.tar.gz 70025 BLAKE2B 2d87390a629d967b0f2aef5f56712d3defc2b460a67f2bf633bb628875161f9ddbb4f229426ce2b42dcf805feefe8101ed3bacd72ced630c0be4fe40bd926c7e SHA512 1aa42498a5875812db922b30eb20cdf124935f95f5cabd224acfb82c9ed61714cfc3c6af2168e75cf11aaa8550e41c48f30fc1d467d1b7be511bf5cb522104e8
EBUILD google-auth-oauthlib-0.5.2.ebuild 876 BLAKE2B 97153977e671f5a8e24315290ce154c41bf478add7b9103141df177381631adfb7a4e7001888a8362ee09f11213c1d461b480436d649d59f9f089ff95c1a25db SHA512 eb04ca36f3939bf0f76b0118ba8c629e39b9bec056c5afd322a2d73b3d655d9af6c2786db17b16f0f7010e0e9f150c14f11cc56671b43e3f876e4477f8ed48b9
EBUILD google-auth-oauthlib-0.5.3.ebuild 876 BLAKE2B 97153977e671f5a8e24315290ce154c41bf478add7b9103141df177381631adfb7a4e7001888a8362ee09f11213c1d461b480436d649d59f9f089ff95c1a25db SHA512 eb04ca36f3939bf0f76b0118ba8c629e39b9bec056c5afd322a2d73b3d655d9af6c2786db17b16f0f7010e0e9f150c14f11cc56671b43e3f876e4477f8ed48b9
+EBUILD google-auth-oauthlib-0.6.0.ebuild 876 BLAKE2B 97153977e671f5a8e24315290ce154c41bf478add7b9103141df177381631adfb7a4e7001888a8362ee09f11213c1d461b480436d649d59f9f089ff95c1a25db SHA512 eb04ca36f3939bf0f76b0118ba8c629e39b9bec056c5afd322a2d73b3d655d9af6c2786db17b16f0f7010e0e9f150c14f11cc56671b43e3f876e4477f8ed48b9
MISC metadata.xml 410 BLAKE2B 23af42a2aa614f119e10cf5d57c3c37abb69ad8d9b1e16445fb92c9f00bdd78f6b1a6a51dff4ebb98bbb03e0002e73eb68cffcf857372dd94848187637c60219 SHA512 c19dd3af098644d5068ec677be51615885bb1267ba9bfb867609725e2a824a74934e2fe25909ea7406c91ca405d44e4c7191a14d3d1bc7b3a60c29445456d3d1
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.6.0.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.6.0.ebuild
new file mode 100644
index 000000000000..9aa755ca297b
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=google-auth-library-python-oauthlib-${PV}
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/
+ https://pypi.org/project/google-auth-oauthlib/
+"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest