summaryrefslogtreecommitdiff
path: root/dev-python/google-auth-oauthlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
commit6d691ad5b6239929063441bbd14c489e92e7396e (patch)
treee294f87b1ce66397fee1273bd6c7131aeb586f51 /dev-python/google-auth-oauthlib
parentd99093fb4bb5652015c06274d64083daa2439e4f (diff)
gentoo resync : 05.03.2021
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/Manifest4
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.3.ebuild35
-rw-r--r--dev-python/google-auth-oauthlib/metadata.xml4
3 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
index cfdc4f3f496d..d06a6acbfa78 100644
--- a/dev-python/google-auth-oauthlib/Manifest
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -1,3 +1,5 @@
+DIST google-auth-library-python-oauthlib-0.4.3.gh.tar.gz 48020 BLAKE2B bc5e575f3eb7b8b876deb13aaff0d1b900555bcbc609259dc72c9f01f595283feffea6aaaf91acf835b313629fe4c4c76dee8ea877b6ae37c3c01633c63909e4 SHA512 f6fa0e525b0aef6f4359954cb2c8020ee86544862318721d439d153cae3e75527b0e0a312572dc936fab7702da8c6af42ce9242d1e73f48c0a822973e470a4a9
DIST google-auth-oauthlib-0.4.1.tar.gz 18687 BLAKE2B 1c9028f6b4c306bbee51fba5b55950d129d56ff5154645a166998c0c720b125202731f1cfed60837b8103d56fcdeeb818e39491b243a8d761969f73d9f88f67b SHA512 123707139353db8e05c81138af834e35007d323f0e19ae79088ad5ca4be86dda6c0df91e2f7794711475227a60312fab9101c91b49817bf8b84866ea6374c943
EBUILD google-auth-oauthlib-0.4.1-r1.ebuild 763 BLAKE2B 9831129d76dbb7e468426c9497146d13b2af4b98eb7f18775aaf355b7f478476f60aac5b8daf71003658df719d2068fbc2a2a9c29925d877e6e09b174bdbfca4 SHA512 64f0879d1219a780fdabf99cb7f862eb0466c1a4c0518885d77ad689f23b0d222140867ab41e15fd07f607c1b40a9f3665a8dc3ba043176a216b1a2d5cf6728c
-MISC metadata.xml 541 BLAKE2B bc6bd1d6e0a6106e267cd5c2fbb96c39db6d63fd659ea9e75d1391406976426080754de74df8712d9f8dbe434ec63b53210b66d9a5c87a267a17ccfa7c648281 SHA512 02022500c530d62d03eed95f458ce2a32278028bf41d014835e9d85c82e658f59c148d064a79cddbd58f717a75f5a8727e0fe4628dcb526327ec913dd82ac0a4
+EBUILD google-auth-oauthlib-0.4.3.ebuild 897 BLAKE2B d27f90b749025c63ee0ccd2e986dc021b21ce0280a2e7779dbbd754a3b68a7d779627459e20f485cd2bb5a41970863e24a84b3e108a216d3185d1806e079e4b6 SHA512 af995c0a3cd0d1ea53895af11fff39bdfd9e10c7b3cc430007332a196b823ba092a73afb210130cfe0523e0d3e42d1bb42800f0e12ade6ccc385f8057ee97b6d
+MISC metadata.xml 642 BLAKE2B 546e4e4860b520979da6b022c0ce1f201e160d6eb08e1b18f2d32666024941250260577fd01e39053691780ac714619de0733c030397a15cc628e7338e703699 SHA512 66690d78d094ba83ff090bfc85110cbc48e727eca5d85a5fcd3bda727b356be13950027f74920fd0f11923afdb914427ae58c23b4d16c9134322a880291e2206
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.3.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.3.ebuild
new file mode 100644
index 000000000000..188128c194b9
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+MY_P=google-auth-library-python-oauthlib-${PV}
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://pypi.org/project/google-auth-oauthlib/
+ https://github.com/googleapis/google-auth-library-python-oauthlib"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+DOCS=( LICENSE README.rst )
diff --git a/dev-python/google-auth-oauthlib/metadata.xml b/dev-python/google-auth-oauthlib/metadata.xml
index 8b0a33ec2229..c8fa5fd039a0 100644
--- a/dev-python/google-auth-oauthlib/metadata.xml
+++ b/dev-python/google-auth-oauthlib/metadata.xml
@@ -9,6 +9,10 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<upstream>
<remote-id type="pypi">google-auth-oauthlib</remote-id>
<remote-id type="github">googleapis/google-auth-library-python-oauthlib</remote-id>