summaryrefslogtreecommitdiff
path: root/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-04 15:14:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-04 15:14:18 +0000
commitf5f1e7d30401ef31b8776c96a80cf5caae0a4e81 (patch)
treecf79465586b83d032475fad7f33894f6cf4efd1f /dev-python/google-auth-oauthlib/google-auth-oauthlib-0.7.1.ebuild
parent0bb8253b38dc8638a46b66ba909c1bfd1054e1ef (diff)
gentoo auto-resync : 04:11:2022 - 15:14:18
Diffstat (limited to 'dev-python/google-auth-oauthlib/google-auth-oauthlib-0.7.1.ebuild')
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.7.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.7.1.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.7.1.ebuild
new file mode 100644
index 000000000000..9f0dd721dba7
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.7.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=google-auth-library-python-oauthlib-${PV}
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/
+ https://pypi.org/project/google-auth-oauthlib/
+"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-2.13.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest