summaryrefslogtreecommitdiff
path: root/dev-python/google-auth-httplib2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-12 10:40:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-12 10:40:56 +0100
commitfc1125ea4b3373e327ba0e157daa1d7e8aee15f9 (patch)
tree44c9694d007e95c09700bf72177701759333a717 /dev-python/google-auth-httplib2
parent5d5e56d92268c2b9b6ccc38eeaa3516ce9b1e8fd (diff)
gentoo auto-resync : 12:09:2023 - 10:40:55
Diffstat (limited to 'dev-python/google-auth-httplib2')
-rw-r--r--dev-python/google-auth-httplib2/Manifest2
-rw-r--r--dev-python/google-auth-httplib2/google-auth-httplib2-0.1.1.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/google-auth-httplib2/Manifest b/dev-python/google-auth-httplib2/Manifest
index ae805cedadc5..a9601b329593 100644
--- a/dev-python/google-auth-httplib2/Manifest
+++ b/dev-python/google-auth-httplib2/Manifest
@@ -1,3 +1,5 @@
DIST google-auth-library-python-httplib2-0.1.0.gh.tar.gz 25116 BLAKE2B dbb0393bafb1bbe67b99ac0783e687271c42256c7b283422b884b86d4c8a83222392a5514b812aae683ec7f887afa4bf81307079e676f793f02eb87e52a375e5 SHA512 52b0faf70e185cb89420377a06c77e2c45f6b910b85371fc2c42fdfb06a4ebca28b476201f9d179fbaa4a8bf7b6015703d023ddd95d482113e2cdbf79fd376b5
+DIST google-auth-library-python-httplib2-0.1.1.gh.tar.gz 43818 BLAKE2B 629e370d3509c8d7b47b9192f3192b013be184df8e245cd73941d233645344f019b760e92ed2119c3b0c1e6b5db0ebf74f52f7c56bd34f8c6f61cbb41311814d SHA512 2272c7019b0f47344c45d45d88f9a9de5be410764dda5ea22271a8661856abf3b3c5d92937aa126f51c385dc91b5c79578fbb81570d7f4b636a3229ad0a95403
EBUILD google-auth-httplib2-0.1.0-r3.ebuild 945 BLAKE2B d34fe18fcc43845700af9952da0b9cf7fbcf62747de39d32e27087c345b810fd38a9f8f3fb6a234418a7bb2d0a5275ff93ce60a3bfcc50aa653fd6e800519ece SHA512 90c60ab6b24cd8f1beb2544566c3ddaf35b21c2b2c0384a6a20165f1a2d9a11f575a8ad5bd5927ff014aff7d915daba804b8ae3a21930d8b99fa1d4f68e2bdfe
+EBUILD google-auth-httplib2-0.1.1.ebuild 913 BLAKE2B 39050d32ea17f753728696c56c3c641045459e6176dad0b6dd387a315e43b442152fb42ae8b2f46b889830c32d641a8d688b23eac2133ac3f96ceee5a6263125 SHA512 fb7dc06d2a66d82fcd63334656bc43212bd5866366a2d3f464f3ee2ddc900444d6b0b8e3026edd4ae52d7abe782033ef76f057c30e48f4d8b58a13630b657ddf
MISC metadata.xml 539 BLAKE2B eefbb5db5d696a71dbc67ace7becb705ac048632e0434e516aa2fbc6e963ea86713beb4b1a2109e29e16b9844c2bf62ebbec527379c13f0f390d2cdae23e77e8 SHA512 03b6328fffb6014d3cccac0687e2b652b5522f345c125ec69c62dc020a8a6baaef444dbdfadef6dd8119d1a19449d57893e207ae4f2ac35d5592c23cad931c2c
diff --git a/dev-python/google-auth-httplib2/google-auth-httplib2-0.1.1.ebuild b/dev-python/google-auth-httplib2/google-auth-httplib2-0.1.1.ebuild
new file mode 100644
index 000000000000..74cd7713007c
--- /dev/null
+++ b/dev-python/google-auth-httplib2/google-auth-httplib2-0.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P="google-auth-library-python-httplib2-${PV}"
+DESCRIPTION="httplib2 Transport for Google Auth"
+HOMEPAGE="
+ https://pypi.org/project/google-auth-httplib2/
+ https://github.com/googleapis/google-auth-library-python-httplib2/
+"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-httplib2/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/google-auth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest