summaryrefslogtreecommitdiff
path: root/dev-python/google-api-python-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-24 00:07:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-24 00:07:11 +0100
commitaa4954f71a3ba2293395a8cce2321a70c39c7554 (patch)
tree35665855d8a569dca2bdf52a7316e2503df68208 /dev-python/google-api-python-client
parentb3b92de25c3fc5f6bddc5e513027140591a0b2a5 (diff)
gentoo auto-resync : 24:05:2024 - 00:07:11
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest2
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.130.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 8ef64e7820c2..6baccf725b12 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,5 +1,7 @@
DIST google-api-python-client-2.128.0.tar.gz 11193400 BLAKE2B c9762dc89a2dda1bdf96f6ae4b4f3540627510900cfccd6153e2399be7d835afdd1513854a9f25577e24e7555aa81b9bc0df06e8685c3f39871233655c9dc083 SHA512 9edd8c9c7b6736e98652e2abc4e482fae176e72cf5b04521b9ca2d0a86b885766a956b451d78dab038a5cfc7d7709eb2a505f03a07393decc3f3be8673400c88
DIST google-api-python-client-2.129.0.tar.gz 11153292 BLAKE2B 0d2e909fb592d1b54721143b88f5a841bf53f9dde11fa555aa1384bc306f3648463578886069695568f4491b2d13cc4993adb7df47988fe3440f93c973764e68 SHA512 73b93847f3b2dc2ef722edc033fec6f292b16acbf81227276c34b651915854556ae58eb160baa462bf868aa988e194ed462ff235532f5ca1a35a234bb1eda8e5
+DIST google-api-python-client-2.130.0.tar.gz 11178249 BLAKE2B 8f89f85124f72fa1c23ef6ab2d8e0eba2935ae14bf3528102de977aeec6b6b525f51f6d6d574e582b010ad49f6d8ac450cdf6edae7653a6b47b15868754e6ea4 SHA512 3553a140a86974cbf05cf21b4792f59adb3dee23e50772c8b6d285868ef08566bda8a64895b7054fa3f340dac0c9f52b4a712eba3fabea8feebca7390149e0ed
EBUILD google-api-python-client-2.128.0.ebuild 1475 BLAKE2B d19c13ce0fe0968d44016c0c7b2a023f393c31af0758473d6996d06b87cf1c950757f442ac4a0d2f460f848ca45cc3b185d92eedf81249d63204b2c2b952096e SHA512 1c58462ddc1ed7da0d7130fda6daf0e6df229d5de9b99a6b9fd44489827554254025389543b40f7db725ce537ffc85c51551ea9512d4abefb02bade4613050b9
EBUILD google-api-python-client-2.129.0.ebuild 1478 BLAKE2B 4660fef51f05bc038cb079a4680f3cb5ce0fb8b6c0cbe609470d5a3e1106eb76da26fb969040e8eaa250581513a96fabc09b66b32641441707ab741ef9732ee8 SHA512 152bb175cb77bb8bec3da99cea918d8b2ad709d2f5ea671c30181b04a3ffb26656ccf8fa9301132019fb47f81253411ae7612e9c7271d3cb0d0d4ea6df9bc163
+EBUILD google-api-python-client-2.130.0.ebuild 1478 BLAKE2B 4660fef51f05bc038cb079a4680f3cb5ce0fb8b6c0cbe609470d5a3e1106eb76da26fb969040e8eaa250581513a96fabc09b66b32641441707ab741ef9732ee8 SHA512 152bb175cb77bb8bec3da99cea918d8b2ad709d2f5ea671c30181b04a3ffb26656ccf8fa9301132019fb47f81253411ae7612e9c7271d3cb0d0d4ea6df9bc163
MISC metadata.xml 538 BLAKE2B bf0b8ab3a89ce9ab1d2159f4c0ebfe3f2646aced20bd2006485510c12d22e83cc130fac979f699ae6431a610c8d2acf86c04b39bc262abaf167c20571a860810 SHA512 30d004d944055660165954f8475e57ba45cef56423c80a324118836d78e5376261409955155a40c9bd988f230f3e2fc44c6aeb6fae3028c78c55a382ccd83bff
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.130.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.130.0.ebuild
new file mode 100644
index 000000000000..224056fade87
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.130.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ tests/test_discovery.py::Universe::test_client_options_universe_configured_with_mtls
+ tests/test_discovery.py::Universe::test_universe_env_var_configured_with_mtls
+ )
+
+ epytest tests
+}