summaryrefslogtreecommitdiff
path: root/dev-python/google-api-python-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/google-api-python-client
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest2
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.36.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 401f2ad8fbef..be1d7cc8c0dd 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,5 +1,7 @@
DIST google-api-python-client-2.34.0.tar.gz 28469433 BLAKE2B aa2c8849b629fe489cf39cddd410a40a0af0bddfa5f370a4a41c1446aeadf69cd4592eeb1d76e6c63da9737906801aea9c8a4d706328b63a7bf5b34a43b83e00 SHA512 321dfdd3ba821beabc6c3a96575afd06c75a0c8e3db61b1ff5fa9db472e62de81b037c435a1051d6294c2a37e471bcaa068cd27ad7434a3416231d31931dd74e
DIST google-api-python-client-2.35.0.tar.gz 28553015 BLAKE2B 8ff92145f280e090b8f43c10e425dd4a8fe65b4cf565c5b5a0df2813cdb8ba1bcea50e37556efb9dd0b270a21fe11b7d6d1b445c8fdaa83326c7dc6230ee1fdb SHA512 4d0325b79250a26ae252568759e8345d31d692aa1d8f1d7aae623bb9a1a950efae654cd689d39f30450789c6d4fa9ca264111f8a9e798820cf6d0c3acba904f6
+DIST google-api-python-client-2.36.0.tar.gz 28624616 BLAKE2B 738d89e740ded848683a4bc5c1d4b27f57acb817c54397ed563de376fa395d1202c47fd4b42046f313b31c826fb3d0fc2e3761c0779bf9c9718b3b2923fc63a3 SHA512 bdca303fa84f5cb510102265ebb7629b48b939c8d7a01420e61635ef4c461f62b6dfa6f29e96060a80d86baf0ea6587d88b0ec64a7b4c6b32563921c3a1a53ca
EBUILD google-api-python-client-2.34.0.ebuild 1377 BLAKE2B be3e2d39923cc9be436e5b0f60e55f58789b1b1f1b64095ecce75037fa823b288016e74e2c3f6eef4370fdd5037e6d7f7aed9ccea86119b4e2497843a83283c3 SHA512 d3dc2686aa60ffef541f4dfb2cb1707403cc180e845d6d7ea3d27de4c1cefc19baa9a64eb6ca21741d69e9626bd8295df395d21ffca5216221534a7ef16404c8
EBUILD google-api-python-client-2.35.0.ebuild 1379 BLAKE2B 642429bd1cae61fd100116b60e2e44acae4bd61f2b905deeaf397539b267974778d533e56a8b65a14bf8e4ade6778508591e4928ec711861c20ac59e75bba9ec SHA512 a7b60dc3f434c0c42322279ac14d691f40697c47828758ffd2860a1ad6b50cc57969a75ad5f605b08adf7fd4f34f335e779bad38d06f77aa05d347a4050a91af
+EBUILD google-api-python-client-2.36.0.ebuild 1370 BLAKE2B 9476872da95b9a1d3c9bf3a92b96fbafeee8de56b0610a51cea9270f9caba10c72275c3e696e437938e1acead667ecd2399e9db6b88bf7d3ff35cb673aa96f74 SHA512 62dc4e10a94c512e55601ab0dfd9675b0882fe3571b9c3c8dcdac37e473b9f424e0e928e02ff4349397f2f682eb736a65ca4c6a146ba2b9bf9406950df2b3475
MISC metadata.xml 538 BLAKE2B bf0b8ab3a89ce9ab1d2159f4c0ebfe3f2646aced20bd2006485510c12d22e83cc130fac979f699ae6431a610c8d2acf86c04b39bc262abaf167c20571a860810 SHA512 30d004d944055660165954f8475e57ba45cef56423c80a324118836d78e5376261409955155a40c9bd988f230f3e2fc44c6aeb6fae3028c78c55a382ccd83bff
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.36.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.36.0.ebuild
new file mode 100644
index 000000000000..13b520b44abe
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.36.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/googleapis/google-api-python-client"
+SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}