summaryrefslogtreecommitdiff
path: root/dev-python/google-api-python-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-30 07:42:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-30 07:42:23 +0100
commit560c9b9748b885a005f22dac90f6e2622fe9ead5 (patch)
tree9eb65efc966093e8a40428f27a93ca0807af1d29 /dev-python/google-api-python-client
parent38c20fb51b0482ec1b2c2a34ed16227718eac4b2 (diff)
gentoo auto-resync : 30:06:2023 - 07:42:22
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest2
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.91.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 7d2681e7e6b4..722a50112c77 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,5 +1,7 @@
DIST google-api-python-client-2.89.0.tar.gz 10965040 BLAKE2B 819c9f0837b86acc693158830c54e48778a1c8ef1fb549a4fbbe100827d0a269b435c4c29d8683c674981ef7817a0489e1cd6639adb7c9b09951c05b8fcf3aef SHA512 e3541f7e6b151ade5feb6e50f22c26b63b85304c4254929be5776c44c6cd80a4c2660d62fc052777033705d3c6a7e8dcd1a69f7f5d3dd5dc49549237a2ce6a5f
DIST google-api-python-client-2.90.0.tar.gz 10891311 BLAKE2B 0683e95e12e5f2faaa5ce5b3f4c82e65df00da0c884530917dd086d33dda74a66e62fd27c7edead205f9d330800d2c60929fce68ce7f82fc04f8787cae010cdf SHA512 331812b50c2816f407db25f703817bf0d20b9218de39bd91c67d40a1f113141c8b9af0210d9d10272ebf51b90485fa44f636e821de19add72eeb38fa04ffe449
+DIST google-api-python-client-2.91.0.tar.gz 10853485 BLAKE2B 3f31a18187701f833e06f514150acf5eec72d6dabdb8b3493efa8fff79f10848a2108c5c7114f0f467519bd2f943162cdc3cbe91c9805a65a74d80c6ca41b745 SHA512 638783176e9d98af621deb5ee10ad5418108910f0996e98653adfa252dee2edd8db712c8fc0fe73d7d83db14a770d297b34d3334c5b018ce800325ef2dd91e04
EBUILD google-api-python-client-2.89.0.ebuild 1314 BLAKE2B 4b94f53adfddc78245531b7528b46e0f22ea97b1c3a2f856657d9239308e302abb13d95c75f7118e12c459f8350c035cea63691a55db8c9c089345bb1353e67e SHA512 ea3465da7f85594297f735b66d1e2378e2b2eceb530da38dda71ef2ff0ab26f5abddc8c0cfaafbd34abb040e114c67e55c71aa9a3e84fcede68ee298b1f32fbe
EBUILD google-api-python-client-2.90.0.ebuild 1316 BLAKE2B d6d158b0cdd8c45d8d79dbc2977291d7e3342c7f53da3adcb227708ae8f3161413381d971dddf63b941a32b94133a6cd4c661d7b76863a5d3162db0495fdceaa SHA512 762a1b2c0e8c06f60e01fd9045abc4255999039a97e86145bdbe8ea7727d2bbfd3defd6c6e932a726f0efe001cb0364d1640f2a808c531ff57ec66d8740d9d13
+EBUILD google-api-python-client-2.91.0.ebuild 1316 BLAKE2B d6d158b0cdd8c45d8d79dbc2977291d7e3342c7f53da3adcb227708ae8f3161413381d971dddf63b941a32b94133a6cd4c661d7b76863a5d3162db0495fdceaa SHA512 762a1b2c0e8c06f60e01fd9045abc4255999039a97e86145bdbe8ea7727d2bbfd3defd6c6e932a726f0efe001cb0364d1640f2a808c531ff57ec66d8740d9d13
MISC metadata.xml 538 BLAKE2B bf0b8ab3a89ce9ab1d2159f4c0ebfe3f2646aced20bd2006485510c12d22e83cc130fac979f699ae6431a610c8d2acf86c04b39bc262abaf167c20571a860810 SHA512 30d004d944055660165954f8475e57ba45cef56423c80a324118836d78e5376261409955155a40c9bd988f230f3e2fc44c6aeb6fae3028c78c55a382ccd83bff
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.91.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.91.0.ebuild
new file mode 100644
index 000000000000..0194f9640998
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.91.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}