summaryrefslogtreecommitdiff
path: root/dev-python/google-api-python-client/google-api-python-client-1.7.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/google-api-python-client/google-api-python-client-1.7.9.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/google-api-python-client/google-api-python-client-1.7.9.ebuild')
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-1.7.9.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/google-api-python-client/google-api-python-client-1.7.9.ebuild b/dev-python/google-api-python-client/google-api-python-client-1.7.9.ebuild
deleted file mode 100644
index 140bfc9d35cc..000000000000
--- a/dev-python/google-api-python-client/google-api-python-client-1.7.9.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Google API Client for Python"
-HOMEPAGE="https://github.com/google/google-api-python-client"
-SRC_URI="https://github.com/google/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/httplib2-0.9.2[${PYTHON_USEDEP}]
- <dev-python/httplib2-1[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/google-auth-1.4.1[${PYTHON_USEDEP}]
- >=dev-python/google-auth-httplib2-0.0.3[${PYTHON_USEDEP}]
- >=dev-python/uritemplate-3.0[${PYTHON_USEDEP}]
- <dev-python/uritemplate-4[${PYTHON_USEDEP}]
- >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
- <dev-python/six-2[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- test? (
- dev-python/google-auth-httplib2[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- export SKIP_GOOGLEAPICLIENT_COMPAT_CHECK=true
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests --verbosity=3 || die
-}