summaryrefslogtreecommitdiff
path: root/dev-python/google-api-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
commitab3da91fb6c91a9df52fff8f991570f456fd3c7a (patch)
treee8f3bfa2c6c3d20ec3b9c352c839e23949068b6b /dev-python/google-api-core
parent6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (diff)
gentoo resync : 18.12.2020
Diffstat (limited to 'dev-python/google-api-core')
-rw-r--r--dev-python/google-api-core/Manifest2
-rw-r--r--dev-python/google-api-core/google-api-core-1.24.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index be3976c7c515..27da290a0233 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1,3 +1,5 @@
DIST google-api-core-1.17.0.tar.gz 98660 BLAKE2B 7959f429dbbfd8de658b11d0ee5be253cb53d930f8b37a140dbdc89a0d25ecdc640fc91476138471603efbe1e6078d668bc3f0e06c1fb1481960970a6f5632dc SHA512 fd609ce85bde22b09653bf46dd7bcc504ed93b19f8832c28f1d26ecb38a01e00380bd715191152a8d109e8c3235951b60525d4692fb4ba0eccb11a3b1df58cd2
+DIST google-api-core-1.24.0.tar.gz 129718 BLAKE2B 08bb8aef03d5f5cbc96c06c01d103e1e569f15bad5084ba24a5e13f732b10d9d97a299fe22db7dfdaea73809e9458b811de87a028f77dcb00ca62fc069af63b1 SHA512 9517e86389edb824fe178128003fa245857de47f4b2416e0a345b66e02fe5fb109b7a72f2e9adfd52478862165548ce6945761a5a2ca02eda4a0187ca608760b
EBUILD google-api-core-1.17.0.ebuild 1224 BLAKE2B 9b4d3118dfa4105a7c701142273e5aa2183869feed9302fcfff72eae45494a038ea7a13c00a6b4238c6fe5f1456ad406b6657462cb07af6e35f1d5992796e43e SHA512 c33c10cb137204895985ae4ef0a857563e99b0a2391db01ef8512c8fc7fe57fcdbc0fe9e457fac6d17ecb6b44626b25c1be2d4d157fb19003aaf04743f0d329c
+EBUILD google-api-core-1.24.0.ebuild 1305 BLAKE2B 6d28195087e5a78b57a56965b05f9cd7ecb1b69d3800440dce3ea4cc95a4764aef714eae0c1258625a2c7a67103803bfa1a2e3f9a84c5e50685d7a176f378eaf SHA512 8f86430095ef2ec15fc35132c6abb302040f616aca3bdcfa481b7dfb1a4451ce2e7eab6cdf500f44fbabfd5906419cd899130d3314769066b202fe52a19eda9b
MISC metadata.xml 351 BLAKE2B 81b265b23499e957c079d50ecaebdbcd5664fbec610c3d4fecc6c3448aff8cbaeb0eb7cf7bb7083ba0d3b9656cc5ff5130e472b13b86d64efb5463d722bc645e SHA512 3c8e6297e14fe4f13574f89f7e9a625fa51998d682460bb85d5081b5636ae16d96df7a0865d19025f2de13c71df2e51bb3f80bd89fd4e080912e9ca5425ef666
diff --git a/dev-python/google-api-core/google-api-core-1.24.0.ebuild b/dev-python/google-api-core/google-api-core-1.24.0.ebuild
new file mode 100644
index 000000000000..78bdc1d03c09
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-1.24.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="https://github.com/googleapis/python-api-core
+ https://googleapis.dev/python/google-api-core/latest"
+SRC_URI="https://github.com/googleapis/${PN//google/python}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P//google/python}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/googleapis-common-protos[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}