summaryrefslogtreecommitdiff
path: root/dev-python/google-api-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-python/google-api-core
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-python/google-api-core')
-rw-r--r--dev-python/google-api-core/Manifest4
-rw-r--r--dev-python/google-api-core/google-api-core-1.27.0.ebuild44
-rw-r--r--dev-python/google-api-core/google-api-core-1.28.0.ebuild44
3 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index 4f29240af5df..5dea2238956f 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1,3 +1,7 @@
DIST google-api-core-1.26.3.tar.gz 133409 BLAKE2B ca3c63769f87cc79483d5ac52646cb044fa21e4f702a945994aeffad71b5be6bd1105e7aa3ec489c943d8adb1148f1c5eb868d64d71f0bcc4a6084ff470acf05 SHA512 8a7753ee30f6f3bb78265b083d8fb80a48021ab32c849ddadaf969263e5a63bfaeb3010b584440d5c5f1c4e0dcd4e8fcd4df16321ccb03d3c0932e19502bbe4c
+DIST google-api-core-1.27.0.tar.gz 134035 BLAKE2B be074208ac51b6e33466a2304e5780894d6a420ccf7ea36e5b98b6d9f920cd6f0cc9f94dababb154731ebe4a36d8b863897f5c654e00068a0f12753ceecb6e8c SHA512 5e8ca58c7f1dc9aa3e612ea635feb84a115c0f21bde2a3152cd54be5b041841ab1c0d2c725660794e15d42e63a4b6955a5318d3dec20bbbb3e7d683c630a5f5e
+DIST google-api-core-1.28.0.tar.gz 133640 BLAKE2B 8134e39cc3ff2fbb850d5e774d08589e3e64b83ca5d5209279f5d1b7fc2eb350a523bbe2890fba6d907689149df3872a7e0a11991b1ecc62fc64a4753dce38e4 SHA512 3702d27613e621394209047451729c1308beb88c917033b4340e3fa96bf4a5ec36ad2594c98ed14439c578f69a202d95a96d30472438a30417484cff6e06fe7d
EBUILD google-api-core-1.26.3.ebuild 1260 BLAKE2B 41e5da2c64d6ae327135c47f9b14ea57e226d765aa948b2acedb8a895f0d603cf39cc79340401072538dd54326865d5d2f6ef9c0cf9db21ece6c9c8d34fa42ee SHA512 fa476f9c48b5d7c0aebdde04e1044535544d2ca1b518e158011ef82474defdcb377bb6cc38f0be11c1b28cbb2a5717bb357e8006bc98a0c0b88dfed84ad1c8fb
+EBUILD google-api-core-1.27.0.ebuild 1262 BLAKE2B 80d50ffd74520f2ecd050586bedb1067db37be45bc7879ca0abecb09d2e027f4a1c70e0bfc38750ace23ba4acd28235e09464c966a95239511b04454a97d8f51 SHA512 1840aa564a0b56f8d887e6446ce68f57f109e63029fe6dfa50bf1ad0df174656ab4f9bbce50498e3c1f937d855c20d9f4aa0df039e709ed8ee04b32c3dbde11a
+EBUILD google-api-core-1.28.0.ebuild 1262 BLAKE2B 8e04c7d42723eb278fbc64d756445bff4a21778218034b866e4f98adff762b36ac4a3f72e315bb9f876abd56219ff919a56b555df69a9fd9be9494fe03609fc8 SHA512 04e0a2dd047625d8376375d324dbfaadcf489deeae355cb743592520e903e7b4be754eec0e07a50dad736d24f68684423929aa01b2b590b793090d95420721d8
MISC metadata.xml 452 BLAKE2B 0fcfeaec5750606a31eecf6794110c23bee9e2e56c9aa18201568e9ca8b1b45ef538efb4d0700eef7ddb28729acbc23946daf2c88c1cbe4f4f309d635455080c SHA512 0bb4089469ba140ff630b358150bc7ccb646465da9ae7b83ddbbb980b10347e0d3cb7b7e86cd8d0ab5897aa6a34017f6a921978a8ded784ef7582b00552299ae
diff --git a/dev-python/google-api-core/google-api-core-1.27.0.ebuild b/dev-python/google-api-core/google-api-core-1.27.0.ebuild
new file mode 100644
index 000000000000..af52a0d1189f
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-1.27.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="https://github.com/googleapis/python-api-core
+ https://googleapis.dev/python/google-api-core/latest"
+SRC_URI="https://github.com/googleapis/${PN//google/python}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P//google/python}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/googleapis-common-protos[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}
diff --git a/dev-python/google-api-core/google-api-core-1.28.0.ebuild b/dev-python/google-api-core/google-api-core-1.28.0.ebuild
new file mode 100644
index 000000000000..de335d4f57b5
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-1.28.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="https://github.com/googleapis/python-api-core
+ https://googleapis.dev/python/google-api-core/latest"
+SRC_URI="https://github.com/googleapis/${PN//google/python}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P//google/python}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/googleapis-common-protos[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}