summaryrefslogtreecommitdiff
path: root/dev-python/google-api-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-python/google-api-core
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-python/google-api-core')
-rw-r--r--dev-python/google-api-core/Manifest1
-rw-r--r--dev-python/google-api-core/google-api-core-2.7.1-r1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index 36fae1556899..e423de99d512 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1,5 +1,6 @@
DIST google-api-core-2.5.0.tar.gz 160336 BLAKE2B 5a3050dcb2e58c068c67cd6263b297ea84e4a47784c750e7ed87077bf46314730698eda2eaa8305a99a55b539b8886dfbbeeb9dc9838748fa941db6785212f36 SHA512 92b570195db21dded50b220e350e518c13101ab3e247bcbb3d3f5701e722c6dc81312443889360fdef1485edf1d5ef486bfeecf56092844cea81b61c7c527728
DIST google-api-core-2.7.1.tar.gz 163942 BLAKE2B 0b28e8dd8607ed6a64a3715c14e321f74d18abc09bc2eee5c6d080936160ea9d6839f1acf9589667c86a688e4e02038cc204f25d0b7cab3e3ed3af2463f31abb SHA512 2264eec00309f272ecca278e8f310bca4be64cfcec94c05fa96a7a8ae350fce0ae9931fbb27aae71e89393289cdbef782631a6766e85d5aee449e903e70f0817
EBUILD google-api-core-2.5.0.ebuild 2209 BLAKE2B 9fb7529ee4f407df73536ccbad3277772522335648bae417d7d173485044234b49644709909e28b9b4dfbbef1238ee20dfd730b91890d238e1b13a2a4160c6e7 SHA512 8e483351b024155b158d79c80f6a6d5990e8ed7063fe3a1b063d86012e1889ccdc7992920ade540a1e6247b484bd05a38f05e7a4f3c14e53c3dbba4d6cac66e0
+EBUILD google-api-core-2.7.1-r1.ebuild 2264 BLAKE2B d473eeeaeb06b8d42dac5e7dcf4f41ac8c3762268757009be7e525571733e049f52932b43c763b373f876dabc89d5998d7070f9fc76f022a356895c1cc14944a SHA512 9f8865a403d266f651b6a312968791ce0e7ed21e641ea09c688e11c4eee8126d7b3253aa597f7ab7867002c66839b5195225dea5130a308ca0656b74c6fb4309
EBUILD google-api-core-2.7.1.ebuild 2211 BLAKE2B f87fa536107b72b39605bb7d840ed14e55c187e27778b5445d0add419ccf04da06789a338d185b923b7a36dc100fa5224080f6c65bb393cb8b37c18e4603b407 SHA512 af27ab83fa71f70b1ad6184b6ada4097227377f745b19c584b633088884e83d9a044c2f899ac59045592029e1090a4f94d41e5b1ec16bbf1cca3afa1969dab5f
MISC metadata.xml 453 BLAKE2B b53e834b3c423d8bdceaa2568f38173fc203f92f2340edd42899e4d4a93602118dbdb2283d492e34189155c336ec659d96f907f257b34cbe5557be331169a4f5 SHA512 d26c893b82fa946cab27669148b3dc2dea8b985636209ae49294cb14a7055f6c4a3884b38bce6e4923a54e9872af7e540b33a992eb727caae96e071a8ffe3237
diff --git a/dev-python/google-api-core/google-api-core-2.7.1-r1.ebuild b/dev-python/google-api-core/google-api-core-2.7.1-r1.ebuild
new file mode 100644
index 000000000000..1b480984d792
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-2.7.1-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="https://github.com/googleapis/python-api-core/
+ https://googleapis.dev/python/google-api-core/latest/index.html"
+SRC_URI="https://github.com/googleapis/${PN//google/python}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P//google/python}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/googleapis-common-protos[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+"
+# grpcio support is broken if grpcio-status is not installed,
+# and we do not package the latter
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/proto-plus[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # failing due to missing grpcio-status
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_unary_errors
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_raised
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_read
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_aiter
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_write
+ tests/unit/test_grpc_helpers.py::test_wrap_unary_errors
+ tests/unit/test_grpc_helpers.py::Test_StreamingResponseIterator::test___next___w_rpc_error
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_invocation
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_iterator_initialization
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_during_iteration
+ # TODO
+ tests/unit/test_operation.py::test_exception_with_error_code
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+src_test() {
+ rm -r google || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ distutils_write_namespace google
+ epytest -p no:aiohttp -p no:trio tests
+}