summaryrefslogtreecommitdiff
path: root/dev-python/gitlabform/gitlabform-1.0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-25 08:09:37 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-25 08:09:37 +0000
commit693cc9b6e847a01c1bb692153021aaf9fb0fab25 (patch)
treebb2f7c299a4149f841c37a1208c7ac861aa95640 /dev-python/gitlabform/gitlabform-1.0.7.ebuild
parent09351e78166b5e864197c4456ebae3f89dd0bed9 (diff)
gentoo resync : 25.01.2019
Diffstat (limited to 'dev-python/gitlabform/gitlabform-1.0.7.ebuild')
-rw-r--r--dev-python/gitlabform/gitlabform-1.0.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/gitlabform/gitlabform-1.0.7.ebuild b/dev-python/gitlabform/gitlabform-1.0.7.ebuild
new file mode 100644
index 000000000000..34dcba43fdcc
--- /dev/null
+++ b/dev-python/gitlabform/gitlabform-1.0.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easy configuration as code tool for GitLab using config in plain YAML"
+HOMEPAGE="https://github.com/egnyte/gitlabform"
+SRC_URI="https://github.com/egnyte/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ sed -i -e "/pypandoc/d" -e "/long_description/d" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}