summaryrefslogtreecommitdiff
path: root/dev-python/gitdb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /dev-python/gitdb
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'dev-python/gitdb')
-rw-r--r--dev-python/gitdb/Manifest4
-rw-r--r--dev-python/gitdb/gitdb-4.0.6.ebuild62
-rw-r--r--dev-python/gitdb/gitdb-4.0.7.ebuild62
3 files changed, 128 insertions, 0 deletions
diff --git a/dev-python/gitdb/Manifest b/dev-python/gitdb/Manifest
index a943963f9e41..45189113630e 100644
--- a/dev-python/gitdb/Manifest
+++ b/dev-python/gitdb/Manifest
@@ -1,3 +1,7 @@
DIST gitdb-4.0.5.tar.gz 392815 BLAKE2B ab0c557f1233ec6f454769c3d72d982c876cf7b8f67d8b36f9ed8a6a2ee4a04a7a22e1a7453aad0d128436e679940ffea9b2c1e6d433083634b47ffff08b396c SHA512 a3f562928a863121c4051663a0674aa94937527b2fc40a7f392d2913d4d1443bda278e2f7cf362d499389691d24a2d965ab89a6533d42a157db3ab629a377e83
+DIST gitdb-4.0.6.tar.gz 394670 BLAKE2B 579579981a4597fa540d7f2987fb24b81ee64066349ed479816ce010a94358af9d0821b8abb10886a5b6fdb56e158c398688690d9570495f041f974e3964b5a6 SHA512 b9cf964390cf18894c02e8854ef5099ef239bf4a43ae8659bf3def22a0fc35814c7416fd8b8312d9d0a170e5e0ea84380edbcac47cc435dc9ec1d98cf7f6463f
+DIST gitdb-4.0.7.tar.gz 394664 BLAKE2B 4a4586ac276c719110e7ad9ddccca8c0f45cca42f6740d990a974b043a749148088c495ad1939794382ff4094afa712cfa7f17619f371423f1b7a10e65ce72d2 SHA512 db63a613ee59249a3fccbd09fc0eca5747b166180bb5885737f849e339e81dfacd04f65e438fef241cf013cde33fe8c99a569c1599b2b5defd37b50e87dbdb0a
EBUILD gitdb-4.0.5-r1.ebuild 1354 BLAKE2B f8d9d018ae2dcbcd902c608cfbff10e3d1033e54a48e375e374bc15a2b97514ff2d5c2cb8a3d01a29687a663d36fd9a724aedd958407589910a865aa2772bbcd SHA512 55c9b2ca5988f2c7a1f71aa947e69e7e073635ff54c6d0ede3befef7f8fefd0f91ed0dd6cd81aa8f16631439fe8f337750c09b7fbf5e00121d1c9bf8d7974a83
+EBUILD gitdb-4.0.6.ebuild 1357 BLAKE2B dc8a6bf537984e8837f1da5839de84a449b361a6599cf9e7a7f7d70a36e0804ae4ca385cb82814e681b3c67f3e58482e0bf58b61478e59c543eecd1fada06a4e SHA512 6325c4caed5c4f2e57c70a3431ee7ca7efcaf03b3c8840f1984bbb72e5bf33b0ab70f78baad299f032ecf9a3e50333b3c724999a6ede66b1b9936217a0467eed
+EBUILD gitdb-4.0.7.ebuild 1357 BLAKE2B dc8a6bf537984e8837f1da5839de84a449b361a6599cf9e7a7f7d70a36e0804ae4ca385cb82814e681b3c67f3e58482e0bf58b61478e59c543eecd1fada06a4e SHA512 6325c4caed5c4f2e57c70a3431ee7ca7efcaf03b3c8840f1984bbb72e5bf33b0ab70f78baad299f032ecf9a3e50333b3c724999a6ede66b1b9936217a0467eed
MISC metadata.xml 411 BLAKE2B 270925cade7731451404999603981322c15224b7a6a2580c957af06cf8dbc940adeb40a63452ae6ce11f725a01af58ff56e85c4ba63a92e2027f4c13c81e1689 SHA512 361528c0a12026a9bef55a22d172ca8fbb0f82389ad2e867a2d8bcf65913cff9a2d510121f6b54be00a1d8ccb2bca471e2c3579054d3746fcedae910d4f3b361
diff --git a/dev-python/gitdb/gitdb-4.0.6.ebuild b/dev-python/gitdb/gitdb-4.0.6.ebuild
new file mode 100644
index 000000000000..7b465b4d702f
--- /dev/null
+++ b/dev-python/gitdb/gitdb-4.0.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="GitDB is a pure-Python git object database"
+HOMEPAGE="
+ https://github.com/gitpython-developers/gitdb
+ https://pypi.org/project/gitdb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/smmap-3.0.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-vcs/git
+ )"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ # remove unnecessary version restriction
+ # https://github.com/gitpython-developers/gitdb/issues/67
+ sed -i -e '/smmap/s:,<4::' setup.py || die
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ local i
+
+ mkdir "${T}"/repo || die
+ cd "${T}"/repo || die
+
+ for (( i = 0; i < 2500; ++i )); do
+ echo "${i}" > file"${i}" || die
+ done
+
+ git init || die
+ git config user.email "you@example.com" || die
+ git config user.name "Your Name" || die
+ git add -A || die
+ git commit -q -m ".." || die
+ git clone --bare "${T}"/repo "${T}"/repo.git || die
+ cd "${S}" || die
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ #TRAVIS=1 disables performance tests which rely on the gitdb repo
+ local -x TRAVIS=1
+ local -x GITDB_TEST_GIT_REPO_BASE="${T}"/repo.git
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/gitdb/gitdb-4.0.7.ebuild b/dev-python/gitdb/gitdb-4.0.7.ebuild
new file mode 100644
index 000000000000..7b465b4d702f
--- /dev/null
+++ b/dev-python/gitdb/gitdb-4.0.7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="GitDB is a pure-Python git object database"
+HOMEPAGE="
+ https://github.com/gitpython-developers/gitdb
+ https://pypi.org/project/gitdb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/smmap-3.0.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-vcs/git
+ )"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ # remove unnecessary version restriction
+ # https://github.com/gitpython-developers/gitdb/issues/67
+ sed -i -e '/smmap/s:,<4::' setup.py || die
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ local i
+
+ mkdir "${T}"/repo || die
+ cd "${T}"/repo || die
+
+ for (( i = 0; i < 2500; ++i )); do
+ echo "${i}" > file"${i}" || die
+ done
+
+ git init || die
+ git config user.email "you@example.com" || die
+ git config user.name "Your Name" || die
+ git add -A || die
+ git commit -q -m ".." || die
+ git clone --bare "${T}"/repo "${T}"/repo.git || die
+ cd "${S}" || die
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ #TRAVIS=1 disables performance tests which rely on the gitdb repo
+ local -x TRAVIS=1
+ local -x GITDB_TEST_GIT_REPO_BASE="${T}"/repo.git
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}