summaryrefslogtreecommitdiff
path: root/dev-python/git-review/git-review-2.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-19 12:49:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-19 12:49:59 +0000
commit328b082fd6fb193da715f61a92ff9366ad562a34 (patch)
treebb1cb21fc0cdf0377ed571709e5ff4460f159a76 /dev-python/git-review/git-review-2.4.0.ebuild
parent06617f385b21ef2262c88f17869c15c424e67d21 (diff)
gentoo auto-resync : 19:03:2024 - 12:49:59
Diffstat (limited to 'dev-python/git-review/git-review-2.4.0.ebuild')
-rw-r--r--dev-python/git-review/git-review-2.4.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/git-review/git-review-2.4.0.ebuild b/dev-python/git-review/git-review-2.4.0.ebuild
new file mode 100644
index 000000000000..d524a316ec0d
--- /dev/null
+++ b/dev-python/git-review/git-review-2.4.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool to submit code to Gerrit"
+HOMEPAGE="https://git.openstack.org/cgit/openstack-infra/git-review"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/opendev/${PN}.git"
+else
+ inherit pypi
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+BDEPEND="
+ >=dev-python/pbr-4.1.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i -e '/manpages/,+1d' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ doman git-review.1
+
+ distutils-r1_python_install_all
+}