summaryrefslogtreecommitdiff
path: root/dev-python/gfloat/gfloat-0.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-22 23:59:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-22 23:59:31 +0100
commit1f00990debeffd0052c194989d0a02baac23eb96 (patch)
treeecc3dfafe935354404f7a0689a6ad809ebaba580 /dev-python/gfloat/gfloat-0.0.5.ebuild
parent02eb6576978c38afed5787f6f2dbab8353379d66 (diff)
gentoo auto-resync : 22:04:2024 - 23:59:31
Diffstat (limited to 'dev-python/gfloat/gfloat-0.0.5.ebuild')
-rw-r--r--dev-python/gfloat/gfloat-0.0.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/gfloat/gfloat-0.0.5.ebuild b/dev-python/gfloat/gfloat-0.0.5.ebuild
new file mode 100644
index 000000000000..a3db6988220f
--- /dev/null
+++ b/dev-python/gfloat/gfloat-0.0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Generic floating-point types in Python"
+HOMEPAGE="
+ https://github.com/graphcore-research/gfloat/
+ https://pypi.org/project/gfloat/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ml-dtypes[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest