summaryrefslogtreecommitdiff
path: root/dev-python/geventhttpclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /dev-python/geventhttpclient
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'dev-python/geventhttpclient')
-rw-r--r--dev-python/geventhttpclient/Manifest1
-rw-r--r--dev-python/geventhttpclient/geventhttpclient-1.3.1-r1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/geventhttpclient/Manifest b/dev-python/geventhttpclient/Manifest
index 6b202939fa9f..317bd0d934bd 100644
--- a/dev-python/geventhttpclient/Manifest
+++ b/dev-python/geventhttpclient/Manifest
@@ -1,3 +1,4 @@
DIST geventhttpclient-1.3.1.tar.gz 82598 BLAKE2B 5fef20a74c431ed53be4eedb3ec7e040572ad960363d41dda8b93c8f08f3eb05ba6160676c1c3ed957d1528a12aa297400063377f3788754e9e76401bb3421ae SHA512 a50486e1485c449a821176f0aa139cb05a3c7675fb045086e086cc7bb71d6e1d75191fae6972b381e7e69dba89d23c387464503845badd29fa361e03aa866079
+EBUILD geventhttpclient-1.3.1-r1.ebuild 1167 BLAKE2B 5a4776fb0cd83ecdc48d73718611ebdb74e3e251a42286e19f365b15e7c43e33d3b086e4c301a40d9cf8190d2d6a45f408a65fe75c827bc5641842d2b0d86161 SHA512 c0f25e9adae96580b3220a2702160ed746d88bad2dcca29df6d06b7bef2da161bc14b5ef90967262540d10225ab5a7a3b02436ef0e6bf9790c1a1bbf2bdb9f31
EBUILD geventhttpclient-1.3.1.ebuild 1207 BLAKE2B 9f06db42ea4b6061e9df9bc9ee549ce1c04a589f7d78093ba620e2d551fb20db4a6c31d5efeebc643562242e22eb0930fdcd731f48da98d4788b1c792fd96b4d SHA512 8a7f9daff2f9493af829403ec3974612a57112f1968532ab869c7f7af27b3f73412f40955a13c6e908288536ecc692181f6b540cbc53b9d215d4f4a8b0067f62
MISC metadata.xml 454 BLAKE2B c0c62b4bcb9e480cdbc6739010039421f139999d7df9673d260ee2365073a108479892dce53e86e1f8ec721c9a33d3967bd41e468994331970a583189aa8c0fa SHA512 1739f134e47ed32c68fce16d76684f6c2393f1e25fe0b098499b1362379cca9b7522950ef77afd9d8e063e1e0335e50dc3cd44192d91ef01adfae68c02fd9d96
diff --git a/dev-python/geventhttpclient/geventhttpclient-1.3.1-r1.ebuild b/dev-python/geventhttpclient/geventhttpclient-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..9b10793dfb5a
--- /dev/null
+++ b/dev-python/geventhttpclient/geventhttpclient-1.3.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A high performance, concurrent HTTP client library for Python using gevent"
+HOMEPAGE="https://github.com/gwik/geventhttpclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # https://github.com/gwik/geventhttpclient/pull/82
+ rm -r src/geventhttpclient/tests/__pycache__ || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Ignore tests which require network access
+ py.test src/geventhttpclient/tests --ignore \
+ src/geventhttpclient/tests/test_client.py || \
+ die "Tests failed with ${EPYTHON}"
+}