summaryrefslogtreecommitdiff
path: root/dev-python/gevent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/gevent
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/gevent')
-rw-r--r--dev-python/gevent/Manifest7
-rw-r--r--dev-python/gevent/gevent-1.0.1.ebuild65
-rw-r--r--dev-python/gevent/gevent-1.2.1.ebuild73
-rw-r--r--dev-python/gevent/gevent-1.2.2.ebuild73
-rw-r--r--dev-python/gevent/metadata.xml12
5 files changed, 230 insertions, 0 deletions
diff --git a/dev-python/gevent/Manifest b/dev-python/gevent/Manifest
new file mode 100644
index 000000000000..501bbb036c71
--- /dev/null
+++ b/dev-python/gevent/Manifest
@@ -0,0 +1,7 @@
+DIST gevent-1.0.1.tar.gz 1455636 BLAKE2B 1de7c6986db96f8568a43aef1ff3c9b80b09047fc110a8b994db3cf2de39e7470478b78b631138d0d58ae4e2367f84bd8a45caced8e067d35ba0be98891eb7ea SHA512 4790e06b49536ad15856cf551c7ad4d717be2ceda8bc7d39fc35a0132d21f302e033f3294da426be4f6c0476554163776e5ffd82d89962503a720c453ff96461
+DIST gevent-1.2.1.tar.gz 2808619 BLAKE2B 2e3c15adb33401012951f0f93fe7f17c1c7597bb4021a4a9ebc7ecae390565d9892bb2fffe9cdac4f7e207d97d50da5d335ed8e42070d67d6be617cf955eb0b4 SHA512 22740e8e114869c1f53bcfd6796226927a3a726d4fd49d104b947f0c97546c7490eabea98b4492db794e21d26d0aee85f1e40b01d386a47063b042a719e61726
+DIST gevent-1.2.2.tar.gz 3108671 BLAKE2B f80df00f58ae2f65aa7f65fc9eac5cbf63a0084f24ccebc71ba9bafba72cd48fff2e7d0b1d8de7939dc669d7708e120fc14077cc845fe3ce212d6a80a42b5158 SHA512 1e2dd544cffea62ee32de2e4066b3f4c121058a1211b89da281ec3882f3763217fe2d346ce38b66e27df9f59cfe05bb137d1608a681dd10eaf06a33dc22f531c
+EBUILD gevent-1.0.1.ebuild 1461 BLAKE2B 2d74fcc19654b02d952b6b0b4614633aedc38ad294f359004c59b8ea58e64d869e0eaed913f477147fd42bdb927ec03e178ce6e535cc832ce0afbe8b59bea17e SHA512 e8d65da8ede2d244ab2e9d67c626b84f83b0d1264ef25f63842a7787844411c188019426bd83b412de5fa8c6ce9948efabf29fe128c6e7c10f838d6a8112a76a
+EBUILD gevent-1.2.1.ebuild 1846 BLAKE2B ac52fe91163f2ff60cdd9f0681fc5887c910427cfc284e207bfe61a71d2d9ef3c076c2a71796fa063b7c3d17f835c02a328ac91ceb5695a21808f1d09d7787f8 SHA512 df9cb3451b2c186fed7c7db5d97164fe849bb721ac49c3833891cc1bab4a67874ca065c0c66508bd584433a9ef90f8792df2e37248290308b1421c8a221b2d5f
+EBUILD gevent-1.2.2.ebuild 1856 BLAKE2B e88950d1a0efff78649584c1f745a9212c3e428af471a7522c771ed2c784ef9700adbaeaa51dd54b43d4ebc83497ae1267538f338abed270c49260fdc947a25b SHA512 f9b23e2db58298a567f81eee28a0388814f5deec19ffcec88bb1c47618137997d20bb287abe6949cef157f8f062010f65b90b35ffb8736d2e02b2bd725a8f46b
+MISC metadata.xml 374 BLAKE2B 87fe7f375b08bf4991954e018241ce4b150365409df516a12b79d221a037d718342dae60461663fac1d5af34458d352e287901e15fe68b1074927680055c204a SHA512 443f847333d35cd55f9c33624664569ecc8c2d0b7c74a358a716e0e133072edb0f29abfc36d6fb446db6890ae1319ad9d719a6e65e2bb35f9c9e9259379241fc
diff --git a/dev-python/gevent/gevent-1.0.1.ebuild b/dev-python/gevent/gevent-1.0.1.ebuild
new file mode 100644
index 000000000000..ec966685ea7b
--- /dev/null
+++ b/dev-python/gevent/gevent-1.0.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ssl,threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+MY_PV=${PV/_/}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Python networking library that uses greenlet to provide synchronous API"
+HOMEPAGE="http://gevent.org/ https://pypi.org/project/gevent/"
+SRC_URI="https://github.com/surfly/${PN}/releases/download/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="dev-libs/libev
+ net-dns/c-ares
+ >=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# Tests take long and fail terribly a few times.
+# It also seems that they require network access.
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ rm -r {libev,c-ares} || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cd greentest || die
+ "${PYTHON}" testrunner.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+
+ dodoc changelog.rst
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/gevent/gevent-1.2.1.ebuild b/dev-python/gevent/gevent-1.2.1.ebuild
new file mode 100644
index 000000000000..460316ac31e3
--- /dev/null
+++ b/dev-python/gevent/gevent-1.2.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# http://www.gevent.org/whatsnew_1_1.html#broader-platform-support
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+PYTHON_REQ_USE="ssl(+),threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+MY_PV=${PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Coroutine-based network library"
+HOMEPAGE="http://gevent.org/ https://pypi.org/project/gevent/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~mips ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-libs/libev-4.23
+ >=net-dns/c-ares-1.12
+ >=dev-python/greenlet-0.4.10
+ virtual/python-greenlet[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# Tests take long and fail terribly a few times.
+# It also seems that they require network access.
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ export LIBEV_EMBED="false"
+ export CARES_EMBED="false"
+ export EMBED="false"
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cd src/greentest || die
+
+ GEVENT_RESOLVER=thread \
+ "${PYTHON}" testrunner.py --config known_failures.py || die
+ GEVENT_RESOLVER=ares GEVENTARES_SERVERS=8.8.8.8 \
+ "${PYTHON}" testrunner.py --config known_failures.py \
+ --ignore tests_that_dont_use_resolver.txt || die
+ GEVENT_FILE=thread \
+ "${PYTHON}" testrunner.py --config known_failures.py $(grep -l subprocess test_*.py) || die
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS README.rst )
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/gevent/gevent-1.2.2.ebuild b/dev-python/gevent/gevent-1.2.2.ebuild
new file mode 100644
index 000000000000..993ec1e5a390
--- /dev/null
+++ b/dev-python/gevent/gevent-1.2.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# http://www.gevent.org/whatsnew_1_1.html#broader-platform-support
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+PYTHON_REQ_USE="ssl(+),threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+MY_PV=${PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Coroutine-based network library"
+HOMEPAGE="http://gevent.org/ https://pypi.org/project/gevent/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-libs/libev-4.23
+ >=net-dns/c-ares-1.12
+ >=dev-python/greenlet-0.4.10
+ virtual/python-greenlet[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# Tests take long and fail terribly a few times.
+# It also seems that they require network access.
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ export LIBEV_EMBED="false"
+ export CARES_EMBED="false"
+ export EMBED="false"
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cd src/greentest || die
+
+ GEVENT_RESOLVER=thread \
+ "${PYTHON}" testrunner.py --config known_failures.py || die
+ GEVENT_RESOLVER=ares GEVENTARES_SERVERS=8.8.8.8 \
+ "${PYTHON}" testrunner.py --config known_failures.py \
+ --ignore tests_that_dont_use_resolver.txt || die
+ GEVENT_FILE=thread \
+ "${PYTHON}" testrunner.py --config known_failures.py $(grep -l subprocess test_*.py) || die
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS README.rst )
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/gevent/metadata.xml b/dev-python/gevent/metadata.xml
new file mode 100644
index 000000000000..d0c159e3da9c
--- /dev/null
+++ b/dev-python/gevent/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">surfly/gevent</remote-id>
+ <remote-id type="pypi">gevent</remote-id>
+ </upstream>
+</pkgmetadata>