summaryrefslogtreecommitdiff
path: root/dev-python/geoip-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
commit6d691ad5b6239929063441bbd14c489e92e7396e (patch)
treee294f87b1ce66397fee1273bd6c7131aeb586f51 /dev-python/geoip-python
parentd99093fb4bb5652015c06274d64083daa2439e4f (diff)
gentoo resync : 05.03.2021
Diffstat (limited to 'dev-python/geoip-python')
-rw-r--r--dev-python/geoip-python/Manifest2
-rw-r--r--dev-python/geoip-python/geoip-python-1.3.2-r1.ebuild20
2 files changed, 8 insertions, 14 deletions
diff --git a/dev-python/geoip-python/Manifest b/dev-python/geoip-python/Manifest
index 6024f170c0ae..f233a36219cb 100644
--- a/dev-python/geoip-python/Manifest
+++ b/dev-python/geoip-python/Manifest
@@ -1,3 +1,3 @@
DIST geoip-api-python-1.3.2.tar.gz 35674 BLAKE2B c6c4469164347c8c1a8a5231be25370e806768d7f155832cf759469320d8adbd5efcd002d14d1d95522e8bcb4db12668b28b437b45af669bb336024662908498 SHA512 284209a6894d55ef95844c5c4c7aafff99ebcb13996e5ff64a0c31b38677e13c11d51fd8b0250d0fa097f15805c27b572d5aa12c2b217a839afe3cdd0851c414
-EBUILD geoip-python-1.3.2-r1.ebuild 909 BLAKE2B 90600bbae1951c1b0d5e06882fccc6ecff69d0fcce138dc88dfd36c9fee6dd944b307779e9a07cf47e03ea98afd303a6cc0c9a9ec782ede4c052317a6dd5a0ea SHA512 2674983e97b9aab49cc8b3d9a22b3d8b79ad9a2a1f4580f3844f01e2a68bff7214eaa6ca8d1e4075d5adbcf24a08326dddfe9c76237c2da0e4688d113de6d8bb
+EBUILD geoip-python-1.3.2-r1.ebuild 816 BLAKE2B 669afaba47e5af39767852e4749e60145a4b3ea543a58d59e1fa98ac8a015a7d68b8a6310e97dac738355f4ef19883fd6dbf451b956f88b983e6d2e34e84e2ff SHA512 e87984bc2df3f5a2226555ce3e3b8e5b3da26da7eaad447e7a3f60f981420c951b6c90dcca24cecc14f1f3724ac224435afaaa2f64188d7528e80e487671c2ba
MISC metadata.xml 372 BLAKE2B a64a0eafc20c11334ab112844de60a58eeaec62d2bb88ceb0e72efba9fae4cfd0bb02a169f4913299534cf3243d740a6f0f96fee1448a55bb8d9bffe3ccf3597 SHA512 dfcd2454bac4830995eda03b9fc585ea4f19f3e5fc90c00b57ee75d8d9596dc5dda9294f770481df7b9c6e27dea45f7fcf1f8d6094703121b0eab62f2fb055a0
diff --git a/dev-python/geoip-python/geoip-python-1.3.2-r1.ebuild b/dev-python/geoip-python/geoip-python-1.3.2-r1.ebuild
index 04f3cb2e12c9..6097ed5189aa 100644
--- a/dev-python/geoip-python/geoip-python-1.3.2-r1.ebuild
+++ b/dev-python/geoip-python/geoip-python-1.3.2-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_{7,8} pypy3 )
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
inherit distutils-r1
@@ -12,6 +13,7 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="Python bindings for GeoIP"
HOMEPAGE="https://github.com/maxmind/geoip-api-python"
SRC_URI="https://github.com/maxmind/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2+"
SLOT="0"
@@ -20,19 +22,11 @@ IUSE="examples test"
RESTRICT="!test? ( test )"
RDEPEND=">=dev-libs/geoip-1.4.8"
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-S="${WORKDIR}/${MY_P}"
+DEPEND="${RDEPEND}"
DOCS=( README.rst ChangeLog.md )
-python_test() {
- esetup.py test
-}
+distutils_enable_tests nose
python_install_all() {
if use examples; then