summaryrefslogtreecommitdiff
path: root/dev-python/geographiclib/geographiclib-2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-10 18:45:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-10 18:45:26 +0000
commitf50d60b8eb707b56133e594376e993b98e726b5d (patch)
treebe9f0c658e4e0ace79af92f89becddd06c01c772 /dev-python/geographiclib/geographiclib-2.0.ebuild
parent84e395ce722d1f39cf3ef1467b23eda9c2462017 (diff)
gentoo auto-resync : 10:03:2024 - 18:45:26
Diffstat (limited to 'dev-python/geographiclib/geographiclib-2.0.ebuild')
-rw-r--r--dev-python/geographiclib/geographiclib-2.0.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/geographiclib/geographiclib-2.0.ebuild b/dev-python/geographiclib/geographiclib-2.0.ebuild
new file mode 100644
index 000000000000..e7a7bd36b1ca
--- /dev/null
+++ b/dev-python/geographiclib/geographiclib-2.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python implementation of the geodesic routines"
+HOMEPAGE="https://geographiclib.sourceforge.io/Python/ https://github.com/geographiclib/geographiclib-python"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest