summaryrefslogtreecommitdiff
path: root/dev-python/genty/genty-1.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/genty/genty-1.3.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/genty/genty-1.3.2.ebuild')
-rw-r--r--dev-python/genty/genty-1.3.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/genty/genty-1.3.2.ebuild b/dev-python/genty/genty-1.3.2.ebuild
new file mode 100644
index 000000000000..f178f57fedd8
--- /dev/null
+++ b/dev-python/genty/genty-1.3.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Allows you to run a test with multiple data sets"
+HOMEPAGE="https://pypi.python.org/pypi/genty https://github.com/box/genty"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# https://github.com/box/genty/issues/42
+RESTRICT=test
+
+python_test() {
+ esetup.py test --verbose
+}