summaryrefslogtreecommitdiff
path: root/dev-python/genshi/genshi-0.7.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-28 08:31:11 +0100
commitad6182343997a405079870a2fe91c4e0c6b94595 (patch)
tree4aa7483cd0ad7de54338afc8e7971417abe1dd81 /dev-python/genshi/genshi-0.7.3.ebuild
parente8f81810baa21f490d6910e8e2d424546b72a333 (diff)
gentoo resync : 25.09.2019
Diffstat (limited to 'dev-python/genshi/genshi-0.7.3.ebuild')
-rw-r--r--dev-python/genshi/genshi-0.7.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/genshi/genshi-0.7.3.ebuild b/dev-python/genshi/genshi-0.7.3.ebuild
new file mode 100644
index 000000000000..4eb7be61bec8
--- /dev/null
+++ b/dev-python/genshi/genshi-0.7.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python toolkit for stream-based generation of output for the web"
+HOMEPAGE="http://genshi.edgewall.org/ https://pypi.org/project/Genshi/"
+SRC_URI="mirror://pypi/G/${PN^}/${P^}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc examples"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${BDEPEND}"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P^}"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use doc; then
+ dodoc doc/*.txt
+ fi
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}