summaryrefslogtreecommitdiff
path: root/dev-python/gdb-pt-dump/gdb-pt-dump-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-04 10:56:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-04 10:56:18 +0000
commit4ead5818a5d230bcc875202c487761a9b786e945 (patch)
tree63238d1977f2788cb5b7074037f15810af25bb88 /dev-python/gdb-pt-dump/gdb-pt-dump-9999.ebuild
parentd074d0ba59e3121dba0c27c4a18f1e481f67b62a (diff)
gentoo auto-resync : 04:12:2023 - 10:56:18
Diffstat (limited to 'dev-python/gdb-pt-dump/gdb-pt-dump-9999.ebuild')
-rw-r--r--dev-python/gdb-pt-dump/gdb-pt-dump-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/gdb-pt-dump/gdb-pt-dump-9999.ebuild b/dev-python/gdb-pt-dump/gdb-pt-dump-9999.ebuild
new file mode 100644
index 000000000000..3290d5cd1377
--- /dev/null
+++ b/dev-python/gdb-pt-dump/gdb-pt-dump-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Examine the address space of a QEMU-based virtual machine"
+HOMEPAGE="https://github.com/martinradev/gdb-pt-dump"
+
+GDB_PT_DUMP_COMMIT="89ea252f6efc5d75eacca16fc17ff8966a389690"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/martinradev/gdb-pt-dump.git"
+else
+ SRC_URI="https://github.com/martinradev/gdb-pt-dump/archive/${GDB_PT_DUMP_COMMIT}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${GDB_PT_DUMP_COMMIT}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ sys-devel/gdb[python,${PYTHON_SINGLE_USEDEP}]
+"