summaryrefslogtreecommitdiff
path: root/dev-python/gcs-oauth2-boto-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/gcs-oauth2-boto-plugin
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/gcs-oauth2-boto-plugin')
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/Manifest2
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.5-r1.ebuild (renamed from dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.5.ebuild)21
2 files changed, 11 insertions, 12 deletions
diff --git a/dev-python/gcs-oauth2-boto-plugin/Manifest b/dev-python/gcs-oauth2-boto-plugin/Manifest
index 960d3549b02b..17f9b075e734 100644
--- a/dev-python/gcs-oauth2-boto-plugin/Manifest
+++ b/dev-python/gcs-oauth2-boto-plugin/Manifest
@@ -1,4 +1,4 @@
AUX gcs-oauth2-boto-plugin-1.13-use-friendy-version-checks.patch 347 BLAKE2B 5f0062699487ce5f73a2cbba96a6e8ca30f00a3bdd73b7fd5949eac518e01fbc8912a462951b7307a4da02d6016c869e829040ba530974db579d2d16a8c73197 SHA512 b7354d7b195382213018ac4c6924a042da106affb2b9058f664ab5c57b521f0b7164a5249609ecaccfa343114fb8c47d687a861a17b31700c75ee7ca42432bfe
DIST gcs-oauth2-boto-plugin-2.5.tar.gz 16739 BLAKE2B a8ef124670063eb19119f7ab6cfd3101f68815a61ec183b3c9ac79ac158e3e47f48349b4f3faa0cf83ce9a203ab2f350e61fdd8a87872962bc1b24a8182f741f SHA512 db6810351c8364c9b217e092aa83803cdc7831136b3fa1be4c54f978f919e2e33bdaf32b8d36db359c5a328eb57f7ad2cee219b94d7f60403f27aaa6a6fd53cc
-EBUILD gcs-oauth2-boto-plugin-2.5.ebuild 1424 BLAKE2B 32be3cc5974df25e38949168a92dd87d8e0ef76ce343fb69c9a2f08dfbf82e41fc3414e5a7aef5ce904909c0dd7c7da49347f5ec42520c98f8633e472ad8b11b SHA512 19c7a8cf5fa94c926b0fdde9d8d92beec848852423fd897628b895218d9a3a915d3e94228e98bf66002254cb142506dcf4a2159ec7981750a5d9ebee820264a3
+EBUILD gcs-oauth2-boto-plugin-2.5-r1.ebuild 1402 BLAKE2B 813fd5d05e7bb437382da5da36494f14649249ecd5aa553bf175c33077802b4bf4b62bef320428bf63b0ca93d1d4a20a8ac41dc93d02b1883cd53557a1af1fee SHA512 d6079bb2b0715bbf66e84dc691ec5f80d9aa58ae833e931f674ea93adf2048837242dd384261ddb11637ee49faf850bea87332f89e47e9d073cab077108bb31a
MISC metadata.xml 335 BLAKE2B 11f766d7bfb5e7ddb78ea1d749d3d2d79496d69e07b1054bede831ba7824d8705e064e5842c71206a0c35cea37e40558a6cdafd8ebf8460ee99ff8dce3f26ac5 SHA512 cb494f35eba6442585175997cb16c7d4f6eea841e56f2828386f0894e68a7d917c010264bea46d7b6ae1957633763c66a5b669606fd8b0fcba3b4555fa926807
diff --git a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.5.ebuild b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.5-r1.ebuild
index d653f0df487e..071efa216aa5 100644
--- a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.5.ebuild
+++ b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.5-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -22,11 +22,9 @@ PATCHES=(
)
# Keep versions in sync with setup.py.
-DEPEND="${PYTHON_DEPS}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/freezegun[${PYTHON_USEDEP}]
- )"
+BDEPEND="
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )
+"
RDEPEND="${PYTHON_DEPS}
>=dev-python/boto-2.29.1[${PYTHON_USEDEP}]
dev-python/google-reauth-python[${PYTHON_USEDEP}]
@@ -36,17 +34,18 @@ RDEPEND="${PYTHON_DEPS}
>=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
>=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
>=dev-python/PySocks-1.01[${PYTHON_USEDEP}]
- >=dev-python/six-1.12.0[${PYTHON_USEDEP}]"
+ >=dev-python/six-1.12.0[${PYTHON_USEDEP}]
+"
python_prepare_all() {
distutils-r1_python_prepare_all
- sed -i \
- -e '/SocksiPy-branch/d' \
- setup.py || die
+ sed -e '/SocksiPy-branch/d' \
+ -i setup.py || die
# Make sure the unittests aren't installed.
mv gcs_oauth2_boto_plugin/test_oauth2_client.py ./ || die
}
python_test() {
- ${EPYTHON} "${S}"/test_oauth2_client.py -v || die
+ "${EPYTHON}" "${S}"/test_oauth2_client.py -v \
+ || die "tests failed with ${EPYTHON}"
}