summaryrefslogtreecommitdiff
path: root/dev-python/gcs-oauth2-boto-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-14 06:50:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-14 06:50:14 +0000
commitafa8da78d8135ca28150730e9c60af9d875f0a5b (patch)
tree65e94479f29d7591a1bc1d09d1fc1913d785fe6b /dev-python/gcs-oauth2-boto-plugin
parent4828c25c25aacf399de429d381288982fd7e0d0e (diff)
gentoo auto-resync : 14:11:2022 - 06:50:13
Diffstat (limited to 'dev-python/gcs-oauth2-boto-plugin')
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/Manifest2
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.7.ebuild43
2 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/gcs-oauth2-boto-plugin/Manifest b/dev-python/gcs-oauth2-boto-plugin/Manifest
index c2060d7bb3b6..aebfb89fbbdf 100644
--- a/dev-python/gcs-oauth2-boto-plugin/Manifest
+++ b/dev-python/gcs-oauth2-boto-plugin/Manifest
@@ -1,5 +1,3 @@
-DIST gcs-oauth2-boto-plugin-2.7.tar.gz 20929 BLAKE2B 79db6c7bdf76320c2f74ab5edca0dd1cf7967bd38fb9a7a0a34c05fca3cab51317fb3ebd3e9ba195b42af2944cc951d150e3ee90cc93cdeab176f79d027a9800 SHA512 0ea8d4b01a2da79397e06de9dc0279594017e58e3874a2633b32007590efa2e8a29b5d2127d0218663cf7e63042adcc9801dbbb11bdfcb40d0c5d67c47267a09
DIST gcs-oauth2-boto-plugin-3.0.tar.gz 20908 BLAKE2B 85c20d8b39dde8ed8a0bad887572040b8eb1eab91b41558c57ef7c190fff9cc5e0502579881a08ed514de87d5fe91a393779e2de071a53bb21e2371f8f13c047 SHA512 84cef64c2b0cc5e38685bb39b3939c54ceced2c0995a67787bf3541bf8a93b91ffec3da83094b7d6957d5afb60833c5ba4ffe7fb688ba8aa943c5f72c719e93b
-EBUILD gcs-oauth2-boto-plugin-2.7.ebuild 1211 BLAKE2B 20ec3d0636161344386f906867c25dacc57acb0628579708edf84d0b1c954a7db9b55517caccdd36899001c63c27c9e7eecb16bfe958d16d27675a9916298f6e SHA512 bc1af718b3f5ce71dbd6bf8679c4bfb587b82f65d30e3c131e2881dbf4cb5623a8553d3dd218517250ab4a60971101522c68ef98d021aecdcb8f10206faace61
EBUILD gcs-oauth2-boto-plugin-3.0.ebuild 1212 BLAKE2B a79aff22f28422c09423bc89cc4dd232a56881561f7c81c7ce392df5b435c8e2b3632d0e841b07a7bcbd12aa29a3d31ee389a1aecac8069414e342c70924b52d SHA512 13eab01cbe763bf4a2e3a86a3ceb728fdc6741e5c620dd71dfc197810d6ce8558a073c3a9d39c065b3f1af3d38fa7cd06a9a80523408b373d9b237cb4a29bfdd
MISC metadata.xml 456 BLAKE2B 5846fe15c17d14329e1f44eea25bd0528750cb92c5b0abb1c2413775f13e4a37470a0d03a8a96af4c05cee69d552e913746cef73c7379fb93511f9a1567e9294 SHA512 13c1f905b7e732be95f44268c176fe4e15c0a7b27d64f7581bafc4c0ce943f66d21f3d025b4001e7284404e354f61a6e08a1a2119295918981f7271cb6f04625
diff --git a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.7.ebuild b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.7.ebuild
deleted file mode 100644
index 29da63ab3aca..000000000000
--- a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.7.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="OAuth 2.0 plugin for Google Cloud Storage credentials in the Boto library"
-HOMEPAGE="https://pypi.org/project/gcs-oauth2-boto-plugin/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# Keep versions in sync with setup.py.
-BDEPEND="
- test? ( dev-python/freezegun[${PYTHON_USEDEP}] )
-"
-RDEPEND="${PYTHON_DEPS}
- >=dev-python/boto-2.29.1[${PYTHON_USEDEP}]
- >=dev-python/google-reauth-python-0.1.0[${PYTHON_USEDEP}]
- >=dev-python/httplib2-0.18[${PYTHON_USEDEP}]
- >=dev-python/oauth2client-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
- >=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.12.0[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
- # Make sure the unittests aren't installed.
- mv gcs_oauth2_boto_plugin/test_oauth2_client.py ./ || die
-}
-
-python_test() {
- "${EPYTHON}" "${S}"/test_oauth2_client.py -v \
- || die "tests failed with ${EPYTHON}"
-}