summaryrefslogtreecommitdiff
path: root/dev-python/gast
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/gast
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/gast')
-rw-r--r--dev-python/gast/Manifest4
-rw-r--r--dev-python/gast/gast-0.5.2.ebuild2
-rw-r--r--dev-python/gast/gast-0.5.3.ebuild17
3 files changed, 21 insertions, 2 deletions
diff --git a/dev-python/gast/Manifest b/dev-python/gast/Manifest
index dc625bf50ebc..60b6d155eee1 100644
--- a/dev-python/gast/Manifest
+++ b/dev-python/gast/Manifest
@@ -1,3 +1,5 @@
DIST gast-0.5.2.tar.gz 14222 BLAKE2B b251f9aa54d8bdba318f0c8aa7fe97221615a22b7dec8da99b15078ce0f482ac8ec931b9c0acba3a405f2ab3c820a1c578ab93583f9f84740571dd85a3fcb45d SHA512 2a06245ba93f2c0715f662e32e0865732828deb672bc70c3d70a4969c8a2e4c518354a4a63760eddeba53932d4f8bf0ae0ffab64f1a1ad3b20d5b2d18285cd6a
-EBUILD gast-0.5.2.ebuild 519 BLAKE2B 9841786974e32d5ca46211e9299867c00a272e1918b839aa96e631dd52a31159c549a588b8ef9bd19a3752c5631bf4489755e134bf0767c74c81f2a545bbb08b SHA512 1bb8949623729bf3da13c60f397d1259512ce9b149fd498aef4fcad9dbb941794660daecaafe4a6b98bb21777386d685213db45c517be013b0d87612e62466fb
+DIST gast-0.5.3.tar.gz 23455 BLAKE2B b7263e959178421a7ba1cdb41cb09edbe1c30680573e1ab3b4de114e0bd151d2278be799fcc1a01524bb5ee6f6d6764d9902dd0018e7cbe54ac7a3d1300bbeb1 SHA512 a836be76303591ca7c40596d98a29dbd53f281e277c8c23e3821b2003d4e8aaf4d806e7f532f27c0eadd4bdca5a28dc0a3902245505ab97497b9afbfee0c2e52
+EBUILD gast-0.5.2.ebuild 525 BLAKE2B 23e97cb264c79f759f34d33b1db86704741b66099bb56d7a7cba1add35d1394ad02fde690597f794e1b5afc742a5cdee589fb14cd1a82ac9ec03778f6148f270 SHA512 0775b46d2512faf127b2061c7b89c013dc4f3e183df9a6110f8b59c9337c856ea300cdd1757cf5353820a0771bafd3c680056a22d3e8c7bb5232b9fe0e559a24
+EBUILD gast-0.5.3.ebuild 472 BLAKE2B d9303c2a2388b0ad0ee60eb2fe98c9a9d32cb2a9022970653b706536ef92f56b7bab171b65889d32fb5d363ef5eb2c7eae8ee890c164c000b900ec6732f450b0 SHA512 cbc743654a47796b9aa904820a3a360972d8f7d3b90a144d0fbd91176260f659e43a77cb718b6998cc277e61ef30311c433844e2beaba11e996c6364b7446310
MISC metadata.xml 677 BLAKE2B 2c536c1a53fd3be71dae57488b28f71af9e27dadf2987ecf3967bd74e30ee688fcd598f995d7e0b1b74694668b92699036a8049c54698e389d71687a06df6587 SHA512 9330e92aebd0ca5ead979f70d86540c5b416b60580d45c6b7f8f02e4753bfab476d9b1a22dd7ba32f1167be5512983d275cfe07f57757c484aeb8619e836e13c
diff --git a/dev-python/gast/gast-0.5.2.ebuild b/dev-python/gast/gast-0.5.2.ebuild
index 2c5de66e6388..a79cedee6467 100644
--- a/dev-python/gast/gast-0.5.2.ebuild
+++ b/dev-python/gast/gast-0.5.2.ebuild
@@ -12,7 +12,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv ~sparc x86"
+KEYWORDS="amd64 arm arm64 ~ppc64 ~riscv ~sparc x86"
BDEPEND="
test? ( dev-python/astunparse[${PYTHON_USEDEP}] )"
diff --git a/dev-python/gast/gast-0.5.3.ebuild b/dev-python/gast/gast-0.5.3.ebuild
new file mode 100644
index 000000000000..79c5c560fed1
--- /dev/null
+++ b/dev-python/gast/gast-0.5.3.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A generic AST to represent Python2 and Python3's Abstract Syntax Tree (AST)"
+HOMEPAGE="https://pypi.org/project/gast/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests unittest