summaryrefslogtreecommitdiff
path: root/dev-python/fuzzywuzzy/fuzzywuzzy-0.18.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-20 10:17:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-20 10:17:50 +0100
commit399fa07bfac673a8846466b16c76549e329b55b8 (patch)
tree29af17ef91f1bd986b8e615a96b61db7fad5df14 /dev-python/fuzzywuzzy/fuzzywuzzy-0.18.0-r1.ebuild
parent388a0747e5972613060d5ca13955b5cd7132533d (diff)
gentoo auto-resync : 20:05:2023 - 10:17:50
Diffstat (limited to 'dev-python/fuzzywuzzy/fuzzywuzzy-0.18.0-r1.ebuild')
-rw-r--r--dev-python/fuzzywuzzy/fuzzywuzzy-0.18.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/fuzzywuzzy/fuzzywuzzy-0.18.0-r1.ebuild b/dev-python/fuzzywuzzy/fuzzywuzzy-0.18.0-r1.ebuild
new file mode 100644
index 000000000000..69ab35341208
--- /dev/null
+++ b/dev-python/fuzzywuzzy/fuzzywuzzy-0.18.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fuzzy string matching in python"
+HOMEPAGE="
+ https://github.com/seatgeek/fuzzywuzzy/
+ https://pypi.org/project/fuzzywuzzy/
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ dev-python/Levenshtein[${PYTHON_USEDEP}]
+"
+# pycodestyle imported unconditionally in the only test file, sigh
+BDEPEND="
+ test? (
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest