summaryrefslogtreecommitdiff
path: root/dev-python/fuse-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-python/fuse-python
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-python/fuse-python')
-rw-r--r--dev-python/fuse-python/Manifest2
-rw-r--r--dev-python/fuse-python/fuse-python-0.3.1.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/fuse-python/Manifest b/dev-python/fuse-python/Manifest
index c9760593ba87..ffc95f3fd3ec 100644
--- a/dev-python/fuse-python/Manifest
+++ b/dev-python/fuse-python/Manifest
@@ -1,3 +1,5 @@
DIST fuse-python-0.2.1.tar.gz 57833 BLAKE2B 99da322bfbfec193d2e4dfacedfd4e08a885152d1f1ceac19f49288be642c722d7776208dfdef5019b28a03cc00432e898744345041a7d615582c34668fb47a6 SHA512 f89c738352ca23e92b5c0222dde0a13bbee4d86432e9c339080203ed5bf4f885c42a0a3a252ed485f26b569d87e68dc0d78c55d8f7b2f3ce0cbac8afb251bdaa
+DIST fuse-python-0.3.1.tar.gz 45391 BLAKE2B c89d53bc99dc203cb56288ab36ebc6acfa1f5f7a21e10ff6aa12cb601a363d50b06b361ee17310c55a886592b13c789af4f5e86592b7f7af103fd56aefa6402e SHA512 88c01c1f9ca3cd9738711a621b782ec190adaf068a79fdea2c362d865c38fea73706dab48b8346b21502d6b4d404403a261f96e2570254809976a3018060e188
EBUILD fuse-python-0.2.1-r1.ebuild 406 BLAKE2B 1fcda89353995a57c036f1917f7b86bc416a882ea5ac1ef3eefa7d68c24e943371c155971fde7decf6c417044252febce7a0f774a7a8986853f723d04e843238 SHA512 2ab2f2dd29b167ff026baaa698038e481d2de2266feb87ef9e2c71bc472bcefc5b397bad6a3154d74e6a8774bf855ca3b7a0ff94f72509b38e0112ee8180ed44
+EBUILD fuse-python-0.3.1.ebuild 553 BLAKE2B 34085f9447c6d77892091d5755101f243b20e9a53778f4dde3a4146b7526a4e590930caabba2fb74582a34a0c545ae656dd000ae3fd6dac3c2f12c0caf96252d SHA512 f65f2f6f2570f1f8a0e47da89e414bae4f1b1ed48d0617a29e5f5978f8d8317eb9566630bbe53b5cc296db8cd9a63a5b8a66fc974eee4f2c0a81e861b0226473
MISC metadata.xml 241 BLAKE2B cacf8034dd7b4cfc624467a8d32b4a0f0b97ebf3ba84ee4572d491ab3da93098f7ae1c765efed3a6c2372cc859098ebf0853753c35d7b23d9c92bcb04e426f11 SHA512 fae6c0b9c2f7b479a2ae029b5e79207756486f5c59a9fc5a2094b239464270eb7a18928a34c11237811a3d1537cd35839778da6704ee6ea3fd806c76e3e6bb6a
diff --git a/dev-python/fuse-python/fuse-python-0.3.1.ebuild b/dev-python/fuse-python/fuse-python-0.3.1.ebuild
new file mode 100644
index 000000000000..74f1bc069539
--- /dev/null
+++ b/dev-python/fuse-python/fuse-python-0.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python FUSE bindings"
+HOMEPAGE="https://github.com/libfuse/python-fuse"
+SRC_URI="https://github.com/libfuse/python-fuse/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-fs/fuse:0="
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/python-fuse-${PV}"