summaryrefslogtreecommitdiff
path: root/dev-python/funcsigs/funcsigs-0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/funcsigs/funcsigs-0.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/funcsigs/funcsigs-0.4.ebuild')
-rw-r--r--dev-python/funcsigs/funcsigs-0.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/funcsigs/funcsigs-0.4.ebuild b/dev-python/funcsigs/funcsigs-0.4.ebuild
new file mode 100644
index 000000000000..5116da873ead
--- /dev/null
+++ b/dev-python/funcsigs/funcsigs-0.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python function signatures from PEP362 for Python 2.7"
+HOMEPAGE="https://pypi.python.org/pypi/funcsigs"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/unittest2[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ esetup.py test
+}