summaryrefslogtreecommitdiff
path: root/dev-python/fudge
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/fudge
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/fudge')
-rw-r--r--dev-python/fudge/Manifest5
-rw-r--r--dev-python/fudge/fudge-0.9.6-r1.ebuild39
-rw-r--r--dev-python/fudge/fudge-1.1.0.ebuild35
-rw-r--r--dev-python/fudge/metadata.xml11
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/fudge/Manifest b/dev-python/fudge/Manifest
new file mode 100644
index 000000000000..cd8f2f2c73e3
--- /dev/null
+++ b/dev-python/fudge/Manifest
@@ -0,0 +1,5 @@
+DIST fudge-0.9.6.tar.gz 81653 BLAKE2B 106a0c774f9eb2f90beabfa1d84f55febaafa6c6e650b8d194464d9b7bdcf3b3ed18b943d0b7cad143f87febc75047d956d66521675c1f917f7835bf8585edd2 SHA512 69b2fa5bdd678779c0a8d9863a67e1e6724828720d2764f9f8958bc3598dcf39b22f9827efccb03014961d27d6e214c2125f639bab200b63c824c2306e3bb617
+DIST fudge-1.1.0.tar.gz 86418 BLAKE2B 3264b693bb8d4e8a0849c480b48ee79e4e99a88a819f94bfab9c098fd8ccef1171f3f0a8ca7632f29b2c22998d0847e53fcc613bbdf8ac4c1fe33aeae406997c SHA512 061d9303d28509d4e22eb2036d041359f872be85911dd85bb16e4d13bfc1cf27637f8206f215f4a37d63108ab2500d2af3f6a1a3e206fe461ead9163e0519417
+EBUILD fudge-0.9.6-r1.ebuild 911 BLAKE2B cff4278a8393d6343699d93b820bba98988160cea85d20fdd8a0d58812b300140b2743933f6194b9c527685323fcfe5dcf31f4d822f1ffd5fb360a73ef26dccd SHA512 5afd275bd86c364c0c946b4aff6db457f9cb2ea7386253439186a3d35ebc43c712919922de49766dbf982ad9441eaeae7cff4f366992803e826b955d841a61dd
+EBUILD fudge-1.1.0.ebuild 874 BLAKE2B a520b67f73a04a78e12b2c3600c8cee78c4cddc0543d2323f1309b34983a29d7bd695b4c8cb2a3b864a5e974fc243412c7707539092b6cab9aa32a7b2abecc08 SHA512 ec8b8217c8457abebfa043ed7dc8b99be956f174a8168c5ee7edcec96721962b8f64c6e7f1de4b086da47468d17f614cd4c4453a7a54e101f0402f7966c0db50
+MISC metadata.xml 308 BLAKE2B 515b12cd0857952a40c85fdb530340408506cdc4b33f54609b1489fd9ca458f8ee25d195f7cf3b151ca2d219451766714406d7788d7fabc718d2f0f234e5e588 SHA512 b453f365fc5bb8e91cf95982d92096d7f952f4d4cdef59ec1cc41e53a6e2e4861d815db845174952791a1ff67007c8c076151b2a12a1730d3ea03471cab02c56
diff --git a/dev-python/fudge/fudge-0.9.6-r1.ebuild b/dev-python/fudge/fudge-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..ff7d192d2c4f
--- /dev/null
+++ b/dev-python/fudge/fudge-0.9.6-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Replace real objects with fakes (mocks, stubs, etc) while testing"
+HOMEPAGE="http://farmdev.com/projects/fudge/ https://pypi.org/project/fudge/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ find -name "._*" -delete || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests -w "${BUILD_DIR}"/lib \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/fudge/fudge-1.1.0.ebuild b/dev-python/fudge/fudge-1.1.0.ebuild
new file mode 100644
index 000000000000..1b5365d283e3
--- /dev/null
+++ b/dev-python/fudge/fudge-1.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Replace real objects with fakes (mocks, stubs, etc) while testing"
+HOMEPAGE="http://farmdev.com/projects/fudge/ https://pypi.org/project/fudge/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests -w "${BUILD_DIR}"/lib \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/fudge/metadata.xml b/dev-python/fudge/metadata.xml
new file mode 100644
index 000000000000..f231f09e26e7
--- /dev/null
+++ b/dev-python/fudge/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">fudge</remote-id>
+ </upstream>
+</pkgmetadata>