summaryrefslogtreecommitdiff
path: root/dev-python/fsspec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-28 07:59:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-28 07:59:59 +0100
commitb8325835c82367d22428eb41afa0f2d375338d3c (patch)
treec416b8853bd14fc346da5d0129843cc4a68a30a0 /dev-python/fsspec
parentd2ed973482fdd800013658e83a61709b29e0a80f (diff)
gentoo auto-resync : 28:06:2024 - 07:59:59
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest4
-rw-r--r--dev-python/fsspec/fsspec-2024.6.0.ebuild2
-rw-r--r--dev-python/fsspec/fsspec-2024.6.1.ebuild56
3 files changed, 60 insertions, 2 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index 773e527d273d..d647fcfb149e 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1,3 +1,5 @@
DIST filesystem_spec-2024.6.0.gh.tar.gz 409087 BLAKE2B 2ef06faec98173f0a13be365f1f9debca11e4587557b50a0b546b49c014782f4ab70c008a0a12158ce156dd5052b06fe67e9135f414f0c8a5829bf15b4b96f07 SHA512 97ecc5622787dc96d4cc05e7474da214405ae34d1eeee125752133258ea8c0ed9278d8d868544102a271431b01b797adea3834b3b2441e09c85dea01b56af066
-EBUILD fsspec-2024.6.0.ebuild 1385 BLAKE2B 5de7a514b6c4ea495afe5cba1b2989cdaceb224ca6ecf08441cd3270ff9edeb1307227fb9f8fc63819f788babcf3c4fe24ca1222098a990b5cbcc9405085f64f SHA512 6e2c891c1aa2f30a1b40b9297ab9db18f18037e519ea79dac6d83533a249780593f9246c4ef6ee9d01ef6f5cacfd25cea69f3d3f276d3ae76ec7a4da3baa5ca4
+DIST filesystem_spec-2024.6.1.gh.tar.gz 409416 BLAKE2B c5b2ba4935dcf0a141c952d611b49c4370a07e3c9ed439ae4d7e98f86e93610a2b1eb8c394eb73ed4494555cca1ac169f1ee7b11144cf0d1ecae7316a46092b6 SHA512 67ecf2bc10c3ae28fa64be5ecb659fc466e97b52b152f3f223d347931b04730e58a48e90d7c546a47c5422831103711037fc268c24984cf77ef65ca4714b0e5e
+EBUILD fsspec-2024.6.0.ebuild 1385 BLAKE2B eaaa1dc24cd20232b13cdee77bbf2b3482e59f8ffcb51358ac0b6bc2da1154d014b3132cdfe0fc3532f0c017fcd861d6d95ff1b3dd6595b4711210e44c19d83d SHA512 8285972ae0e1a58e9157fa506564fd6d147483ead9d0846eb6022b8caf5e617c74a2ab6381bb776f2c59589baa5b30d1af5754a5ee01df41ced77fc23681709a
+EBUILD fsspec-2024.6.1.ebuild 1388 BLAKE2B 4901c87aa1bed71632dd70ef7e20bc6e9f3d01b49ad1d12b570e8b5515c43835601645e3ebd8d36dce9c06acc7d121cdaf129c7bbc68db646840f3202807f4bf SHA512 1eb7a0e9e109ce4ab3b6325882006384b8f0751835e5db55ff9610184b505f72fecdc3b8450acac72e79c254730d99306a63ba2e3ddbf2ba3333247879f2f1b0
MISC metadata.xml 374 BLAKE2B 6c0b18a0ad3b85713ae6f618ac0646ed63f08549bd7d1ed5bd94b80d89d79efaf2f97ce913a0a7d6e54e77cc602994416520a22deadcc71e484cf7ca22bc6dde SHA512 5bf051387d6bcffb3022d023f60ee8f76ca277bb8d626dda988a0baaf1d1e3a71e872d8316607ee7e269e579b5a17c23ab93c56fade533150171d3ce44e4bb71
diff --git a/dev-python/fsspec/fsspec-2024.6.0.ebuild b/dev-python/fsspec/fsspec-2024.6.0.ebuild
index 141b79ef0b7d..e06e223520d0 100644
--- a/dev-python/fsspec/fsspec-2024.6.0.ebuild
+++ b/dev-python/fsspec/fsspec-2024.6.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
diff --git a/dev-python/fsspec/fsspec-2024.6.1.ebuild b/dev-python/fsspec/fsspec-2024.6.1.ebuild
new file mode 100644
index 000000000000..a1a42e4ef47b
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2024.6.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="
+ https://github.com/fsspec/filesystem_spec/
+ https://pypi.org/project/fsspec/
+"
+# upstream removed tests in 2024.6.0
+SRC_URI="
+ https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+# Note: this package is not xdist-friendly
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p pytest_mock -o tmp_path_retention_policy=all
+}