summaryrefslogtreecommitdiff
path: root/dev-python/fsspec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /dev-python/fsspec
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest3
-rw-r--r--dev-python/fsspec/files/fsspec-2021.06.1-ujson.patch32
-rw-r--r--dev-python/fsspec/fsspec-2021.06.1.ebuild51
3 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index f17252c798bc..f4a8c4ed9e97 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1,3 +1,6 @@
+AUX fsspec-2021.06.1-ujson.patch 1304 BLAKE2B 9a7a7580b7df2967c4d61b7334cb4561cc4a1ce056b9dab3d16bca132545edf6651291c6b69742421208c679b336017b0e92d7584ec24bf32eb26335a451b917 SHA512 5574a57ba32b678a35967c9560831feb993b5462ff986e2b4c9a3a93dfa497ceee206bed88a72cc41456dc255cf8aab4240f6c3fd624822cbe594c6839758324
DIST filesystem_spec-2021.05.0.tar.gz 292796 BLAKE2B 5d56d860ced1a72c27d2031b7d257a4bcbd52f6b2fed5275fbcbf7088375fde26652f0a003e919ebd3948d5e9833d802304234282ca858a7a2a19bfa11f66aa8 SHA512 7c27a1ad4e21efdcc0f31f91a9929e4c09db7b9421e7bf8d2f485e961f6887a4a5c083f38f8d7b09005a4cf11f55c93cce4617e3dc6c2b241ed20f7847ad711e
+DIST filesystem_spec-2021.06.1.tar.gz 297254 BLAKE2B e360c0780df2ace31a2a7e15f7269f23140ddbc6bd6a1f657cfddbab2b1f285d79a0c88f8d63e406d4a53fd3737f77012eb9837479707a778ab043503ade9d18 SHA512 1d59c2c53b1a4a604ff3762eca8484d7ed60fba98548cc77d7ed014ddf1513cef046ceeec41911cdecd414bdbb4e3c669a3a3f65da08dabf5a70cc2985d06b73
EBUILD fsspec-2021.05.0.ebuild 1194 BLAKE2B 0fafb3ea6563b4cab99f604ebe85a5515556a1018f850f0c154feb87f7e3aa7e65a304b4c4d9c244feb36563051706280a09de761a9782f1bfb9db3f2a150b43 SHA512 8b7cfc0266f9ff8a2f60b7853b356b357d98714e43f7074940ff57d2abf7d1e2636bf6498bb33a6ca2b59b9a2d3162471033ef97b9a05f9d5f390c94cd095fef
+EBUILD fsspec-2021.06.1.ebuild 1241 BLAKE2B 0a79be9a0a6e0b512c24e86753380d98b38d81c31aec99dd08e42abac5aeab4f95abbeaff38c0ae89507e7a677117d01aa36535cd2730f066120a8a3f3733a07 SHA512 9319a05c1b9dc4be33a51fd3ba43b91bcb21bf46048e06df630086ff3e4a413fc83f48b255c2081070606ac56d7e88928803b4dbbd4feb081d218cdb687ec5da
MISC metadata.xml 373 BLAKE2B 8932a3ec06759eeef7bb91a181e07ceeef606995e944a6396d21ee6f9b26a7958e9c40f9f54ae27ebdfb9c7974b1ad79963213bb7a5b9bbb282cf35967a1ffe9 SHA512 42e44963570b3b003550ef6f60d1557866a72f362a3d98ca2a7900377422921134e4c8b7bcb6af3ea8bc061b433e4aba96de4fa5643a1f424cc64665a7efd654
diff --git a/dev-python/fsspec/files/fsspec-2021.06.1-ujson.patch b/dev-python/fsspec/files/fsspec-2021.06.1-ujson.patch
new file mode 100644
index 000000000000..0c76d8ac71df
--- /dev/null
+++ b/dev-python/fsspec/files/fsspec-2021.06.1-ujson.patch
@@ -0,0 +1,32 @@
+From 270423008d401d9f03a31f08c53a7b13fa193573 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Wed, 23 Jun 2021 09:23:31 +0200
+Subject: [PATCH] Fix test_unmodel to accept ujson encoding without whitespace
+
+The ujson encoding for test_unmodel data is b'"Conventions":"UGRID-0.9.0"'
+(without a space after ':') that breaks the test for me. Update
+the test to make the whitespace optional.
+
+That said, I have tried multiple ujson versions, going back to <3,
+and was not able to reproduce the output with space.
+---
+ fsspec/implementations/tests/test_reference.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/fsspec/implementations/tests/test_reference.py b/fsspec/implementations/tests/test_reference.py
+index a1a8fdc..15a32d5 100644
+--- a/fsspec/implementations/tests/test_reference.py
++++ b/fsspec/implementations/tests/test_reference.py
+@@ -104,7 +104,8 @@ jdata = """{
+
+ def test_unmodel():
+ refs = _unmodel_hdf5(json.loads(jdata))
+- assert b'"Conventions": "UGRID-0.9.0"' in refs[".zattrs"]
++ # apparently the output may or may not contain a space after ':'
++ assert b'"Conventions":"UGRID-0.9.0"' in refs[".zattrs"].replace(b' ', b'')
+ assert refs["adcirc_mesh/0"] == ("https://url", 8928, 8932)
+
+
+--
+2.32.0
+
diff --git a/dev-python/fsspec/fsspec-2021.06.1.ebuild b/dev-python/fsspec/fsspec-2021.06.1.ebuild
new file mode 100644
index 000000000000..38f77d30991b
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2021.06.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="https://github.com/intake/filesystem_spec/
+ https://pypi.org/project/fsspec/"
+SRC_URI="
+ https://github.com/intake/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ujson.patch
+)
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ # sftp and smb require server started via docker
+ epytest \
+ --deselect fsspec/tests/test_spec.py::test_find \
+ --ignore fsspec/implementations/tests/test_dbfs.py \
+ --ignore fsspec/implementations/tests/test_sftp.py \
+ --ignore fsspec/implementations/tests/test_smb.py
+}