summaryrefslogtreecommitdiff
path: root/dev-python/fsspec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-17 00:01:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-17 00:01:35 +0100
commit6c9dc10e04cd513437e046ccca0e51a3d6d4dc7c (patch)
treeb7183e321a607f857cc5c62cfbd5bae7cbfb3982 /dev-python/fsspec
parent66113e7871aede225d661473925cea4cce9e6d23 (diff)
gentoo auto-resync : 17:05:2024 - 00:01:35
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest2
-rw-r--r--dev-python/fsspec/fsspec-2024.5.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index 4dbe3369f4ff..af9222ec52cb 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1,3 +1,5 @@
DIST filesystem_spec-2024.3.1.gh.tar.gz 426712 BLAKE2B 9e9c60f581872559bd667e8e3fadcb5c4c56a727901ffc2328b67da6a4553ae2e4981f143838532faa59deb9b3f3926e1e2f0b2dd86daf49f93a1811d4e668a4 SHA512 6b93543b729eae898a71fb0249ed69973cb1d2dfcf0feac7d40fb69b40e1109739819acbec9f239023b8a5eaaba01377215458cb5c4c806741ed319433d8f570
+DIST fsspec-2024.5.0.tar.gz 400066 BLAKE2B 4f497fa8efe4897958414e2739c06fed54ecd67babb7cbdfeb0c1b595547213aed1fb15f97dbd2f7f61a84fef7f3a96f36bb1ab5a2f4ca94251e7dccd64afe22 SHA512 b8430350c56ecaeca9496b6de7910d7f4423e17beb4250dcb440d9af6ab34ed83e2e9304b474d4b5611a9ee0941c34eba5c62d5a1f7d0cc1384d976ae3266e7f
EBUILD fsspec-2024.3.1.ebuild 1864 BLAKE2B 1ab257d1015b2cd39be95f6370d4082b1800677667569cef6e269b57c4756f5f931387c31c9267c18dcfd755a3478726e06302b01266a077b0432a2c7393b471 SHA512 0b1adda11b7f1ba26f755f4d4d131eb50e98cac476401d1017ca327e0b6eb678e4d49c89fd4f25b5af14c27a58d46de3dfe410ef8245cae91142b0520beab5b9
+EBUILD fsspec-2024.5.0.ebuild 1191 BLAKE2B 4b33d3af053d4e0f345c958ef313bc052a08520c30f86acd947b09260ac7790b17ad33ca6d5e8fd41bc5ea8637335ff81f7d761e24cfa86424a2f00175b56f48 SHA512 acd18e8536f3f1bc70f34183b1a890fe0330b0f9c759625d5b18950fd53b6101b3db699cebd7c53a9597893ef5aa92ca4c7aaefa62620c24709c8e92fdf3d1b2
MISC metadata.xml 374 BLAKE2B 6c0b18a0ad3b85713ae6f618ac0646ed63f08549bd7d1ed5bd94b80d89d79efaf2f97ce913a0a7d6e54e77cc602994416520a22deadcc71e484cf7ca22bc6dde SHA512 5bf051387d6bcffb3022d023f60ee8f76ca277bb8d626dda988a0baaf1d1e3a71e872d8316607ee7e269e579b5a17c23ab93c56fade533150171d3ce44e4bb71
diff --git a/dev-python/fsspec/fsspec-2024.5.0.ebuild b/dev-python/fsspec/fsspec-2024.5.0.ebuild
new file mode 100644
index 000000000000..d5b9c6d035f3
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2024.5.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+MY_P=filesystem_spec-${PV}
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="
+ https://github.com/fsspec/filesystem_spec/
+ https://pypi.org/project/fsspec/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+# Note: this package is not xdist-friendly
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p pytest_mock -o tmp_path_retention_policy=all
+}