summaryrefslogtreecommitdiff
path: root/dev-python/fs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/fs
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/fs')
-rw-r--r--dev-python/fs/Manifest3
-rw-r--r--dev-python/fs/fs-2.4.9-r1.ebuild6
-rw-r--r--dev-python/fs/fs-2.4.9.ebuild53
3 files changed, 2 insertions, 60 deletions
diff --git a/dev-python/fs/Manifest b/dev-python/fs/Manifest
index c1d399282f3f..97f50d943ba0 100644
--- a/dev-python/fs/Manifest
+++ b/dev-python/fs/Manifest
@@ -1,4 +1,3 @@
DIST fs-2.4.9.tar.gz 126022 BLAKE2B bd7406ee0c22171af349bed6096f58bc749af30f3fae6b8532d7a2b07dd7f0a55165f4b4ab413d6ff7c8861fbe7784ae383a984d26c1cdb1bdc9100c4ae0b0df SHA512 594536eccc043547df4ec4fd1fc507d3fad2838ebb46768a11f142c68d42a776f9fa3cda8651421c6255314835a0283407ea49ebdce04af84a1646efaf5391e5
-EBUILD fs-2.4.9-r1.ebuild 1378 BLAKE2B 7633a962d06dcdd51739f05510b8fbd45d5abb1a75acb3cc672be45ebcc45de86302c086fb86ad8f298ee211085d842ca11045284c75215b9cef93917531c7e6 SHA512 f548981a318b4199606204438d4b943bb372b9e05d48e4a689efd5ade1a39eaf279f5a2ccc802e5dfce08aa5685fd69f4834efc2717f88b489a8b3295322db20
-EBUILD fs-2.4.9.ebuild 1376 BLAKE2B 45b632ac7d1b5eced7f0de3f32bd14568423aa001af745fe316567c67f269383abc6869b8022cf70aeb6ec99db37520e349d69f70bbd1a74c756f8f23567e8d3 SHA512 c8123c0669b7146439444a44e1ff12f65f3b951bb4df2323873e93a22f3a8aba845a16874f154a05e3222fc31d1012733a6ffe25bb6489b552e3d197a4f01302
+EBUILD fs-2.4.9-r1.ebuild 1214 BLAKE2B ce3ef26fddbcec68143383bce719186cf298f5a283cd560d660666df6b83b523258b2c1468ebf6aab0b2952082a5c3bc46393eec57db8045e8845fbab5ec40e6 SHA512 7bb1743c9d17768b6aba41b7d1410300674fd9d7583bc6a13f4e6ae0d429ef5a48a0199a456dcad2df34b9d9fc9924b6728da70e1439d43771918849edc7863d
MISC metadata.xml 486 BLAKE2B 69d62d79b3d0e05fb12bbf8a4d4f703f82488cace87e8f42aaace9319c18f564c3c841b5b69a189530ffb760bceb1acb9fce38472af659a6c4ce24b1bddc16c0 SHA512 48e48fb5f3c868fb8e1b9dce7c483c13291659c99e0f19e096204451e1ada83fb0d2334d89a3beb45de11b7e710a3deb9e5777e5c8f905312efe899cbee02d07
diff --git a/dev-python/fs/fs-2.4.9-r1.ebuild b/dev-python/fs/fs-2.4.9-r1.ebuild
index b3ef70757a86..2dc5fca3dcff 100644
--- a/dev-python/fs/fs-2.4.9-r1.ebuild
+++ b/dev-python/fs/fs-2.4.9-r1.ebuild
@@ -39,11 +39,7 @@ BDEPEND="test? (
)"
python_test() {
- # python2_7 tests require dev-python/typing which is
- # now in stdlib so ignore tests. py2.7 is going away.
- if python_is_python3; then
- esetup.py test || die "tests failed"
- fi
+ esetup.py test
}
pkg_postinst() {
diff --git a/dev-python/fs/fs-2.4.9.ebuild b/dev-python/fs/fs-2.4.9.ebuild
deleted file mode 100644
index a68ebf6c8e9f..000000000000
--- a/dev-python/fs/fs-2.4.9.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Filesystem abstraction layer"
-HOMEPAGE="
- https://pypi.org/project/fs/
- https://docs.pyfilesystem.org
- https://www.willmcgugan.com/tag/fs/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/appdirs-1.4.3[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/six-1.10[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-BDEPEND="test? (
- $(python_gen_cond_dep '
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pyftpdlib[${PYTHON_USEDEP}]
- dev-python/pysendfile[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- ' -3)
-)"
-
-python_test() {
- # python2_7 tests require dev-python/typing which is
- # now in stdlib so ignore tests. py2.7 is going away.
- if python_is_python3; then
- esetup.py test || die "tests failed"
- fi
-}
-
-pkg_postinst() {
- optfeature "S3 support" dev-python/boto
- optfeature "SFTP support" dev-python/paramiko
- optfeature "Browser support" dev-python/wxpython
-}