summaryrefslogtreecommitdiff
path: root/dev-python/frozendict
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-18 08:10:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-18 08:10:15 +0000
commitfceeb864f5e0e6155b3f5ed010298e5b7b2f1278 (patch)
treeeae9568ab98ccfbd977dade72fecdd45c670fc9d /dev-python/frozendict
parent517343fddd94e620e94be97ae22eca4b57dc7625 (diff)
gentoo auto-resync : 18:02:2023 - 08:10:15
Diffstat (limited to 'dev-python/frozendict')
-rw-r--r--dev-python/frozendict/Manifest2
-rw-r--r--dev-python/frozendict/frozendict-2.3.5.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/frozendict/Manifest b/dev-python/frozendict/Manifest
index 6949a563dc14..6d44693d85bb 100644
--- a/dev-python/frozendict/Manifest
+++ b/dev-python/frozendict/Manifest
@@ -1,5 +1,7 @@
AUX frozendict-2.3.4-optional-extension.patch 501 BLAKE2B 42d726955d52bf3c4585ce085407be9026fbec3b2f75825f7b58932c93f6157fc99d2a701b38abc94314220c3b02ba02e531beea3e943e8bf3657fd69d875283 SHA512 d1ef784849a68c47b6b2878a576cf22304b00deb1cc8f6814187f295606325fcb056d41e328472c189b8fa45944cc4751022d18287acb9d641c5ad68ca8c38b6
DIST frozendict-2.3.4.gh.tar.gz 307399 BLAKE2B ac6311182ed2ba4925a14a145b4d30a0241978f55ae7a81cebc534ede812ca77097f0f8c7eeb08e8cbd6240e036d3b5035bd3e9b284a55b638c93717e3a20258 SHA512 15acc4fceb5e2228ee3423d4a5b86c529e9bdcb7264f59139cbde6194983901a17da8036bebf53d7d8057ce52666031e90eb1ca358bfd374c651fd60743988dc
+DIST frozendict-2.3.5.gh.tar.gz 307566 BLAKE2B 8d8b7d483e248be5de3c6e689dbb7e8dc40f8a8112456308e6a0e633dee04640aa0bb43edcf07e2a9829b87b8d082aa0926581622372224e9636cca27eaeaef0 SHA512 9e3820f2a24f2362f1be82049df871449a5225a927efa7735a2e9320e3c9f835a4a0a99a0037a3366df55a5744b38e96b358a9cc624defa79f45a5bff4c3b61d
EBUILD frozendict-2.3.4-r1.ebuild 906 BLAKE2B 5588199e3c10b03b863c52cbcbb322aa4142d143f0ab959d8922b8c911f2c667f0c6618039210ca5f96fec858a8b32084db556450d0b7ee5f805a5d820580440 SHA512 8c40f4090f8aa6b4b0761c6f5df2d3469ba2aa3998b13f0fbbe3a85fafac6b99cd3d477361db9d9d67ef263162526b0b5988c20af2e979e331be3b494ae07956
EBUILD frozendict-2.3.4.ebuild 619 BLAKE2B 35b547359779054e3f492babe19f3fc4e64209ef643c23cac4df446878f2c12d1900552599f02ad160c61b6dfde484114e80ce0c75dcbd2cbe7f5acd6842888a SHA512 81787f4fe74eb23914cad4e6e4b0df38e079d6ca6bfc5d3c2e67c28141bbc4278e3ca7b318a7138b236588d174d654756d0865240746946ce6f88703bbdf5caa
+EBUILD frozendict-2.3.5.ebuild 1109 BLAKE2B e0245b59682d9a5e7a457ba3a2d25f5143caff0d4c1ee882605dcea68b258171be8d75b04fc2788b13f5570b2e004eea92750ec6c41d38796f21708ba0757166 SHA512 f77efe82b72202e9b945afefaaf883051c95b7ecd592c60e33b8902526ca75912606de4c6e12dddefcb9b3685df3e42c2176183eb361bbddcfb9ab20a6240ff2
MISC metadata.xml 634 BLAKE2B 362d9aef54a08943047b2f7b04f74d142be6eb74c74d8242460a70e22a3d77d475f588057fbca3ec6f691f2516a52bc23016e694824d092470670e05e98a79d6 SHA512 7f452c4e377081a16c159ca73079a73666dbd862f237516cb3962bfa7a8c4d32f6c68c7bcd5ef37cade10b999fd026178ca2192bd8254d37da642c9bec81137c
diff --git a/dev-python/frozendict/frozendict-2.3.5.ebuild b/dev-python/frozendict/frozendict-2.3.5.ebuild
new file mode 100644
index 000000000000..0cfb1f569acd
--- /dev/null
+++ b/dev-python/frozendict/frozendict-2.3.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+C_EXT_COMPAT=( python3.{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple immutable mapping for python"
+HOMEPAGE="
+ https://github.com/Marco-Sulla/python-frozendict/
+ https://pypi.org/project/frozendict/
+"
+SRC_URI="
+ https://github.com/Marco-Sulla/python-frozendict/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ local -x CIBUILDWHEEL=0
+ # This prevents the build system from ignoring build failures, sigh.
+ has "${EPYTHON}" "${C_EXT_COMPAT[@]}" && CIBUILDWHEEL=1
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local EPYTEST_IGNORE=()
+ # skip tests of native extension for python versions where it is not available
+ if ! has "${EPYTHON}" "${C_EXT_COMPAT[@]}"; then
+ EPYTEST_IGNORE+=(
+ test/test_frozendict_c.py
+ test/test_frozendict_c_subclass.py
+ )
+ fi
+
+ rm -rf frozendict || die
+ epytest
+}