summaryrefslogtreecommitdiff
path: root/dev-python/frozendict
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-24 16:33:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-24 16:33:11 +0000
commitfaddeff65d652bda3291eba255955adb17f1aa19 (patch)
tree4352e6d85ce48c7c8d96159fad4d3dd90602a70a /dev-python/frozendict
parent0e7b1da874d923b9f006e0000023f5fa528140a8 (diff)
gentoo auto-resync : 24:11:2023 - 16:33:11
Diffstat (limited to 'dev-python/frozendict')
-rw-r--r--dev-python/frozendict/Manifest2
-rw-r--r--dev-python/frozendict/frozendict-2.3.9.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/frozendict/Manifest b/dev-python/frozendict/Manifest
index f7c6f9617382..28c653235d1b 100644
--- a/dev-python/frozendict/Manifest
+++ b/dev-python/frozendict/Manifest
@@ -1,3 +1,5 @@
DIST frozendict-2.3.8.gh.tar.gz 310193 BLAKE2B e21d278396bcc10d88dbc6d33c86027308f66c8de84015d1aa186f1f34e74e4be7c915459a694597e277aab0eaaa78fb716e51e5c0f9fba58bb1e8b8d22394bd SHA512 17f610fc12138446908dbd425b8b15d2b6b7d8ad2b41f68b9a03acbd096d173994049b86169c62b51732cacf1e19de77e58cd38edf3422413269bd9e4eb5ca6d
+DIST frozendict-2.3.9.gh.tar.gz 310538 BLAKE2B 9095cc85fc25ddab23a30879a623b4e09557d7c8d27f51199913002d8dffe58e965174360e964a7f87c556d0b282c2fe6718bf01dc4483bb642db431e53dd0ce SHA512 e724c316c9c4f9c11127bd70ac9dd8e9f9012c61797ca55593b405109d09277657c1c3177183051b6f7d8f7ac86e70715a3448136c2c196db5393271a2fd4fb7
EBUILD frozendict-2.3.8.ebuild 784 BLAKE2B 48f5fc0d2387aa62288053052e7fdf7b46559bd1698c7759f48a7829e44a8bd0e1ce9f7e7c03ca87c6faeed772326b7141709bd5a845b6e611e2adf4324f84e9 SHA512 6b6fcee4e82c986fe90d60ffef1863fad6e25e024c25c92663e6d16b1e5bb3ab8e48861f7db9ee64bd7e85c1d4071ad50401222e69fa859ccb516ef0483de963
+EBUILD frozendict-2.3.9.ebuild 829 BLAKE2B 0acdc8de67ba435732ef8f81249f391230b9181d974499b1c53714d91565a0850c17d7d7674131529263b09e8e082c4dd3d21c8360624ef3e89ef2b8fc0af5a1 SHA512 8f2664098f38cb630025b62731bfbd0be7129fc9c11d009dda5c01cdb45a5d40f8bc672a0e516b5f52563f3a9ed309f30bbd16c43831761db6eb5075d1d5dac9
MISC metadata.xml 634 BLAKE2B 362d9aef54a08943047b2f7b04f74d142be6eb74c74d8242460a70e22a3d77d475f588057fbca3ec6f691f2516a52bc23016e694824d092470670e05e98a79d6 SHA512 7f452c4e377081a16c159ca73079a73666dbd862f237516cb3962bfa7a8c4d32f6c68c7bcd5ef37cade10b999fd026178ca2192bd8254d37da642c9bec81137c
diff --git a/dev-python/frozendict/frozendict-2.3.9.ebuild b/dev-python/frozendict/frozendict-2.3.9.ebuild
new file mode 100644
index 000000000000..4b760aa0a439
--- /dev/null
+++ b/dev-python/frozendict/frozendict-2.3.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple immutable mapping for python"
+HOMEPAGE="
+ https://github.com/Marco-Sulla/python-frozendict/
+ https://pypi.org/project/frozendict/
+"
+SRC_URI="
+ https://github.com/Marco-Sulla/python-frozendict/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ # upstream provides a C extensions for python3.10 only, and errors out
+ # if we enable it for newer versions, so the extra effort does not seem
+ # to be worth it
+ local -x FROZENDICT_PURE_PY=1
+ distutils-r1_python_compile
+}