summaryrefslogtreecommitdiff
path: root/dev-python/fritzconnection/fritzconnection-1.10.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-14 06:50:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-14 06:50:14 +0000
commitafa8da78d8135ca28150730e9c60af9d875f0a5b (patch)
tree65e94479f29d7591a1bc1d09d1fc1913d785fe6b /dev-python/fritzconnection/fritzconnection-1.10.2.ebuild
parent4828c25c25aacf399de429d381288982fd7e0d0e (diff)
gentoo auto-resync : 14:11:2022 - 06:50:13
Diffstat (limited to 'dev-python/fritzconnection/fritzconnection-1.10.2.ebuild')
-rw-r--r--dev-python/fritzconnection/fritzconnection-1.10.2.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/fritzconnection/fritzconnection-1.10.2.ebuild b/dev-python/fritzconnection/fritzconnection-1.10.2.ebuild
deleted file mode 100644
index f901bc98be0c..000000000000
--- a/dev-python/fritzconnection/fritzconnection-1.10.2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Lib/tool to communicate with AVM FRITZ! devices using TR-064 protocol over UPnP"
-HOMEPAGE="
- https://github.com/kbr/fritzconnection/
- https://pypi.org/project/fritzconnection/
-"
-
-LICENSE="MIT"
-SLOT="0"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/kbr/fritzconnection"
- inherit git-r3
-else
- SRC_URI="
- https://github.com/kbr/fritzconnection/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
- "
- KEYWORDS="~amd64 ~x86"
-fi
-
-RDEPEND="
- >=dev-python/requests-2.22[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # flaky (relies on time.sleep(0.01) magically being sufficient)
- fritzconnection/tests/test_fritzmonitor.py::test_terminate_thread_on_failed_reconnection
-)
-
-src_prepare() {
- # upstream is pinning for py3.6 compat x_x
- sed -i -e 's:,<[0-9.]*::' setup.py || die
- distutils-r1_src_prepare
-}