summaryrefslogtreecommitdiff
path: root/dev-python/fonttools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
commitab3da91fb6c91a9df52fff8f991570f456fd3c7a (patch)
treee8f3bfa2c6c3d20ec3b9c352c839e23949068b6b /dev-python/fonttools
parent6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (diff)
gentoo resync : 18.12.2020
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest2
-rw-r--r--dev-python/fonttools/fonttools-4.18.2.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 8c8468e0688f..d1aaf7eb1fe2 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,5 +1,7 @@
DIST fonttools-4.1.0.tar.gz 2253792 BLAKE2B 470207d74404851aa111142ad8541d45820ded0212029867c289f2e7741d4b41b4ac824f65555a23d4f3dcc974428537cd319a8787bc4d80f2fb67561a21d1ee SHA512 3d9485cd34b5ea3dfdcc26474e0b21a96811b84eda16341c39165aea72bb09c3cf3360a069b316ae6575a399e26f6518c199180caec7bb959f245ced7ca45e3b
DIST fonttools-4.18.1.tar.gz 2498166 BLAKE2B 9ea9fd372c71883e37756c9b0b5bcd193782d49a99df37e7245f788362b284af8e5b9456c31b1c6b84fb6cccd8bce0339e95c87cecc008f0130e47a40c74bfe5 SHA512 d87c466e87ffa70bb15ee40f889b25e1187d51a1074b6e47a259d5984d51d7ce988ef50db91796fcbd06b5692b2c627d0a4cd76e3be6d0da348c0872ff01317c
+DIST fonttools-4.18.2.tar.gz 2499129 BLAKE2B 1ae93418121942e4303e4b138b192a30195d25c87e8c6204b508cc6a5b7a87608fcde7acbb6a2e8fb3c71ea59938827dabbe1556b7edad537523f6f0b3615696 SHA512 ceec3656c674ff5c43f4dc7cdf1468ddaf5c8bbe569d865fb015a9251ac089caedcf3dcea82c93a0c367576fcd7d65451642a6ab5d3093d941aa391b50070d53
EBUILD fonttools-4.1.0.ebuild 1356 BLAKE2B b062425fc7bc10c18c3c44e0d29c946f0ddda6e24d4345429039c60323e9b9501f192894eebdc8aae1d39c195bd34e8717e9e8fd9716c8cbc0817c697bd2f5a7 SHA512 317ba31531366edbfe474592594dd8c9dbaf19dda856f90dd3e37f4a5fcec214e6a2197a85193ffd962967aeca32dc675785632d927f170ac03c83851fd63e27
EBUILD fonttools-4.18.1.ebuild 1392 BLAKE2B 740f06cc15d4902bb0ddf431911eb2940a98b6c395cac21f9863670d43f4f9ac82fcd9ec473542ee773b1abc7a71f5e51497a8f9e68b17adec8b62d130312ded SHA512 2b6c51fd2aab0c4099359a6c621f18fe0fafdcaf35de9e933c0985d63a8295f5d768f854bb39cde3f25ee4379160816ca7d7cd3551cc43ba6a8ffdc8e239a6cf
+EBUILD fonttools-4.18.2.ebuild 1392 BLAKE2B 740f06cc15d4902bb0ddf431911eb2940a98b6c395cac21f9863670d43f4f9ac82fcd9ec473542ee773b1abc7a71f5e51497a8f9e68b17adec8b62d130312ded SHA512 2b6c51fd2aab0c4099359a6c621f18fe0fafdcaf35de9e933c0985d63a8295f5d768f854bb39cde3f25ee4379160816ca7d7cd3551cc43ba6a8ffdc8e239a6cf
MISC metadata.xml 494 BLAKE2B 2bc2e69cfab3a180d7098efccd9059c14e8eaf75fe29d26272952a7e65a383ae060444f64892cc3b2c185405d59c2cfea5f7fc2e3dbdb68bebf6568cbc4770b7 SHA512 cf381a45630a10358adc449689ce496da052a18e5257c3426c8e52f333a90f254278c2cf9a18770fe08fc7d60b5b50c48fc77bb3b36bf73fba282a3eb8ad5e71
diff --git a/dev-python/fonttools/fonttools-4.18.2.ebuild b/dev-python/fonttools/fonttools-4.18.2.ebuild
new file mode 100644
index 000000000000..c1277db3ff69
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.18.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+PYTHON_REQ_USE="xml(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/fonttools/fonttools/"
+SRC_URI="https://github.com/fonttools/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+RESTRICT="!test? ( test )"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )"
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx pytest -vv Tests fontTools
+}