summaryrefslogtreecommitdiff
path: root/dev-python/fonttools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-17 06:26:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-17 06:26:48 +0000
commit2e0bf408961ec1023d3db1fc5d687c233661ac26 (patch)
tree96c6e46af3c356d1fb470acdf72ada482bb293f8 /dev-python/fonttools
parent48dbe17904ac8ee6f006488d8f21734b0d253db4 (diff)
gentoo auto-resync : 17:03:2023 - 06:26:48
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest2
-rw-r--r--dev-python/fonttools/fonttools-4.39.2.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 1644bd49d550..47f8d9d87118 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,5 +1,7 @@
DIST fonttools-4.38.0.gh.tar.gz 3603281 BLAKE2B 8ec558c35cc10b32760eb199dce7c40934210db9ba8c9b0ad7a8cd2ca206260d2d73769bd1ff4cb597dd46cd50a42d733c967199120366e22abc5ee2b81e0919 SHA512 438694e7a4c19ee63ab504763793c0219d96fdc58095fe55a4f44726e96a3ec8ae63066aa47a341a059c7a2c9893b9bbbdfc8ab4d75c177cbd90986debc31431
DIST fonttools-4.39.0.gh.tar.gz 3673934 BLAKE2B 468f8798b06593f69b4130f06d52134b9c86a414ba534a352e15bb16d787e11a6b692d406e545aa137d5d132aa33684f44e98a520ce13fe6c8e4dcf81fc64e69 SHA512 f9613651082ae8fb0dd3fba66549f90001d8cb3c71785f9e5b692513984d26d63d027dfb67e1dbe1a22c6e8c393e6ed21af1bfcd5b2f766c8534577cbd211616
+DIST fonttools-4.39.2.gh.tar.gz 3694973 BLAKE2B 1a752fe62f5f2e1092e8df8f16a6a9cbb0a6f121bab1d910a2db9bc8a404f749d746aa85b82fd51d3fc1e0aa225b0515d0c3a7d0d25860a7d09afdab8c878c0e SHA512 27d892e2949355ed7762ad969e9fcb950029a82e63cba10e99b5dfc209ab055b46942de740d0ec1dda6bb2461f64565d6a4678c4d89a4d4fe3f37221a863d69e
EBUILD fonttools-4.38.0.ebuild 1554 BLAKE2B f471c0c66b420bdb147bbaf8b33d3df00b4773c7b585503e44350f03c1dc6439c5572146f39869dce51d53148cc65218384a1fbd28855066c6e13bbaedb27782 SHA512 8e202db0ae5e85e34469f59b601628089cc296c244b2ed5ebdddc48b2df2c5a586e57b387fbf5c073b220c751b083058d7560c3516153bdf6765392a13cdca72
EBUILD fonttools-4.39.0.ebuild 1562 BLAKE2B 32d0c71bb8690ec85453b61098663eac1c855cf8e18be7611641ab7c5389b1f03885affd309e1bd79d62ed18367845ae40e348160394f9df1ef92acd71a6dd58 SHA512 91c717e491081d557634e2d62be7b31b038c49203350fb055cff72d921425f5f17b2927e2c175a33b9629526c4707c687748654f8b63b20aa9e8e77136b4f0a3
+EBUILD fonttools-4.39.2.ebuild 1562 BLAKE2B 32d0c71bb8690ec85453b61098663eac1c855cf8e18be7611641ab7c5389b1f03885affd309e1bd79d62ed18367845ae40e348160394f9df1ef92acd71a6dd58 SHA512 91c717e491081d557634e2d62be7b31b038c49203350fb055cff72d921425f5f17b2927e2c175a33b9629526c4707c687748654f8b63b20aa9e8e77136b4f0a3
MISC metadata.xml 372 BLAKE2B 950ec78bf127250847c6513c22a5108b251afdb000d361068edf9d00d64a5baf6925ba4058bb889724febb28d92abc044c29af5936a48d8e8951b12314b64357 SHA512 03e76e28959bab83fe41c3ee4b55692ced9b1360e73e38a6e8f6e5c06fd1185dcbe0214aea2edff18d248abf252c1877d0d2c2b78b8e088e606c09c34e93e7ac
diff --git a/dev-python/fonttools/fonttools-4.39.2.ebuild b/dev-python/fonttools/fonttools-4.39.2.ebuild
new file mode 100644
index 000000000000..8ca55aca7585
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.39.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="
+ https://github.com/fonttools/fonttools/
+ https://pypi.org/project/fonttools/
+"
+SRC_URI="
+ https://github.com/fonttools/fonttools/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ export FONTTOOLS_WITH_CYTHON=1
+}
+
+src_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ epytest Tests fontTools || die "Tests failed with ${EPYTHON}"
+}